cancel
Showing results for 
Search instead for 
Did you mean: 

Developing for the oculus go with unity in 2022?

HolyVampire
Level 3

Hello there,
I need to develop an app for the oculus go with unity and its been going pretty badly so far.

All the guides I've been through have been using the older versions of the oculus integration package from the unity store or the XR plugin.

the problem is that when i use any it prevents the project from working when launching on the oculus go:

importing the oculus integration to the project just makes the screen go black and the app unresponsive.

using the XR plugin shows me a window saying the oculus go needs an update and quits the app.

so my question is - is developing for the oculus go with unity in 2022 using any of the current tools still possible without massive incompatibility issues?
I would be very grateful for any help anyone can provide, I have tried many different settings variations and unity versions but nothing worked out so far, this has been driving me crazy for a few days now.

1 ACCEPTED SOLUTION

Accepted Solutions

Using an older version is the way to go..

The download archive page has stopped listing very old versions but this post seems to show that you can still access them through a specific URL

https://forums.oculusvr.com/t5/General-Development/Searching-for-Oculus-Integration-v18-download-lin...

https://developer.oculus.com/downloads/package/unity-integration-archive/18.0/

View solution in original post

4 REPLIES 4

baroquedub
Level 6

What versions of Unity and the Oculus SDK did you try? The last Go project I made was on 2018.4.1. I can't see from the asset folder what version the Oculus integration package was, but if it helps, the VR plugins folder is named 1.37.0 whereas the current one is 1.78.0.

Hope that helps

Thanks for the reply,
i tried the current unity version 2021.3.14f1 where XR integration gives the update error,
then i tried some 2019 versions where the built in XR settings worked but the Oculus integration package from the Unity store works only with 2020 and up,

then 2020 versions where i hit the same issues as the current version.
Right now i'm trying to find and download a much earlier version of Oculus integration in hopes that will work

Using an older version is the way to go..

The download archive page has stopped listing very old versions but this post seems to show that you can still access them through a specific URL

https://forums.oculusvr.com/t5/General-Development/Searching-for-Oculus-Integration-v18-download-lin...

https://developer.oculus.com/downloads/package/unity-integration-archive/18.0/

I was actually there trying to download an earlier version but i didn't know i could download down to version 12 from there just by changing the number at the end of the link, i downloaded version 13 like i saw used in a guide and it actually launched a sample scene without giving a black screen!

I'm using unity version 2019.4.40f1.

Thanks a lot man!