Showing results for 
Search instead for 
Did you mean: 

Enable Passthrough during loading or splash screen. Three dots background remains black.

Honored Guest

Hi there.

We are developing an MR app for Quest 2 and 3. We can use Passthrough successfully in all our app except during the loading and splash screen, where black background is shown.
We aren't using a splash screen, the three loading dots are shown instead.

We followed those two guides to have Passthrough enabled in the loading screen, but non of the options seems to work:

*We are using Meta XR All-in-One SDK v 63.0
*Insight Passthrough is enabled in OVR Manager
*System Splash Screen Background is set to Passthrough.
*We don't have a splash screen in Player Setting nor in OVR.
*We also tried to enable passthrough background in the AndroidManifest.





Are we missing something??

Also, we loaded a splash screen in the OVR to do some testing, and it was shown with black background.
We deleted the image and all the associated changes after the test, but the splash image is still there in subsequent builds.

Thank you all!






I ended up having the exact same issues, following the guide here:

Honored Guest

Correction: It's working properly on Quest 3, but not on Quest 2.

Honored Guest

I was having a similar issue with the Quest 3 and Unity 6 preview (since we can now disable Show Splash Image in Project Settings > Player using Unity 6).

What I found was that after I made a build of my app with the wrong option for Camera Rig > OVR Manager (Script) > System Splash Screen Background, I believe the AndroidManifest.xml file was holding on to my previous selected option: System Splash Screen Background: Black, because after clicking the menu option Oculus > Tools > Update AndroidManifest.xml I noticed my new build of the .apk would then have the made changes I made and System Splash Screen Background: Passthrough was then finally working for me.

@ani.ta I don't own a Quest 2, but maybe you might need to do the same for that device?

I found this out because I made a whole new project, and built the app, and if I had everything setup correctly then the app with passthrough worked just fine. If I forgot to change the System Splash Screen Background from Black to Passthrough, then only running Update AndroidManifest.xml did the change get made.


TLDR: Try Oculus > Tools > Update AndroidManifest.xml