cancel
Showing results for 
Search instead for 
Did you mean: 

Error installing Unity's Meta XR All-in-One SDK v62 (and 63) package

Luis.Zan
Protege

I'm getting a console error upon installing Meta XR Core SDK on my Unity 2021.3.36f1 project:

[Package Manager Window] Error while getting access token: invalid configuration from Unity Connect
UnityEditor.AsyncHTTPClient:Done (UnityEditor.AsyncHTTPClient/State,int)

Additionally I'm seeing an error icon with a message "Error while getting access token: invalid configuration from Unity Connect" next to all of the Meta SDK related packages. I've tried uninstalling and reinstalling the package as well as updating it to V63 but the error persists. This also happens accross three different Unity projects on all computers in my organization.

LuisZan_0-1712767808777.png

No other package displays this error.

I've also confirmed that my Unity services are all running correctly and that I'm logged in the Unity hub with the same account as my asset store.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Adding Meta's npm.developer.oculus.com as a scoped registry  fixed this for me. I tried manual mode also it didn't worked out. Only scopedRegistries as source worked out for me. Try adding this in manifest file under Packages folder.

"scopedRegistries": [
    {
      "name": "Meta",
      "url": "https://npm.developer.oculus.com",
      "scopes": [
        "com.meta.xr.sdk.audio",
        "com.meta.xr.sdk.core",
        "com.meta.xr.sdk.interaction",
        "com.meta.xr.sdk.interaction.ovr",
        "com.meta.xr.sdk.platform",
        "com.meta.xr.sdk.voice",
        "com.meta.xr.sdk.voice.composer",
        "com.meta.xr.sdk.voice.dictation",
        "com.meta.xr.sdk.voice.telemetry",
        "com.meta.xr.simulator",
        "com.meta.xr.sdk.sharedassets",
        "com.meta.xr.sdk.interaction.ovr.samples"
      ]
    }
  ]

 

View solution in original post

11 REPLIES 11

pranav_suresh7
Protege

I also got similar issue when i Updated the meta xr sdk from 62 to 63.  Now After building the project it just freezes.

andrew.alderete
Explorer

This has happened ever since the all-in-one was released. It's very odd, but what I've found is just quitting and restarting the project fixes it (most of the time). 

Luis.Zan
Protege

Restart unfortunately doesn't resolve it for me.

Though the console error isn't preventing compilation.

Have you tried logging out and then logging in? Also try to clearing the Library folder under your projects root directory. Library folder contains a lot of cached data and temporary files that Unity uses to speed up project loading and operations. Then reopen unity. This worked for me. Also try to keep a backup of Library folder.

Luis.Zan
Protege

Tried both and no luck. It's happening across all developers in my organization as well which tells me this is stickier. 

Therian23
Explorer

In my case, it ended up that my login for the Unity Hub/Unity project was not the same account I had logged in for my Unity Asset Store website. 

I was logged into my work account for the Hub/Project, but was using my personal account for the Asset Store. 
I closed the application, logged out of both. 

Afterwards I logged into Asset Store website first with my business account, and then logged into the Hub/Project with the same account.  It seems to have fixed it. 

VRRMeta
Honored Guest

I'm having this problem as well.


[Package Manager Window] Error adding package: com.meta.xr.sdk.core@64.0.0.
Unable to add package [com.meta.xr.sdk.core@64.0.0]:
Request [GET https://download.packages.unity.com/com.meta.xr.sdk.core/-/com.meta.xr.sdk.core-64.0.0.tgz] failed because it lacks valid authentication credentials
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()

-------------------------------

I've tried the above suggested solution with no positive results.

pranav_suresh7
Protege

Hi Anyone able to resolve this ? I'm getting this across all the unity editors and when starting new project also.

Not on my end. Still seeing the error.