Showing results for 
Search instead for 
Did you mean: 

Hand Tracking Quit Working in Editor



A week ago, both the hand tracking projects I'm working on, would show my hands when I played in editor.


But yesterday and today, I can't get hands to show in editor anymore.


One of my project I'm on a collab team, and everyone else on the team can use hand tracking in editor flawlessly.


Hand tracking works natively in the Quest (Quest home and apps that support hand tracking).

It was working in both my projects last week.

Everyone else in my collab team, hand tracking still works in editor.

I've tried factory resetting my headset. I've tried deleting Oculus software and re-installing. I've tried a second Quest Headset.

I've tried Unity 2020.3.0 and 2020.3.26

Oculus App Version

Unity Oculus Integration Version 35.0

Quest Headset Version 22310100490800000

I can't imagine what to try next. I feel like I've tried everything.

I even tried creating a new unity project. Imported in the Oculus samples, and tried the hand tracking Train sample. No hands ever appeared.



Software update system version: 22310100490800000
Runtime Version:
OS Version User: 22310100490800000
On my team, there are two Quest 2 users, and one other Quest 1 user.
Hand tracking is working for all of them in editor still.
The Quest 1 user, is on a different version of the Quest OS.
He is on:
Is it possible v37 broke hand tracking in the unity editor? At least for Quest1?

 This may not be your problem but just in case... I had exactly the same thing happen to me and eventually found that the problem was caused by the additional plastic grips on my controllers. Hand tracking was still working as expected on the Quest (just as you say, in the menus etc.) but for some obscure reason, when in the editor the controllers were more sensitive to the grips being present and essentially thought that my hands were still gripping them (and so not allowing hand tracking to kick in).
May not be your issue, but since you've tried everything (as I did at the time!)... 🙂

Thanks for the reply. 

I keep the batteries out of my Quest Controllers. I never use my controllers as everything I'm working on right now is hand tracking only.


This is getting ridiculous.


I have deleted all references to Unity and Oculus from my computer.

I rebooted my computer several times.


I used add/remove programs to uninstall everything.

For unity hub, I went into the unity hub folder and ran the uninstaller.


Every editor version I uninstalled.


I went into the AppData folder, and removed all references to Oculus or Unity from all the folders inside AppData.


I rebooted.


I installed the latest Unity Hub.

I installed Unity 2020.3.0 (my biggest project uses that version).

In project settings I added Oculus to the XR Plugin Management.

I installed the Oculus Integration from package manager.

I had to comment out lines 267-278 in OVRCameraRig.CS due to some errors related to 'LateLatch'.


I ran the Train demo scene for hand tracking, and hands will not be displayed in the headset when in the editor.

I can use hand tracking in regular quest menus and any apps that support hand tracking.


Hand tracking just won't work in editor.


The last person I spoke with from Oculus said it wasn't even possible to use hand tracking in the Unity editor...and now Oculus support won't respond to me anymore.


Anyone have any ideas?


Did you ever find a fix for this?



Unfortunately,  it required me reinstalling my operating system.

Ouch, sorry to hear that.


I just changed the plugin from OpenXR to Legacy LibOVR+VRAPI and that fixed it.
I still haven't made it build, but I think I'll have to switch back and forth.