Showing results for 
Search instead for 
Did you mean: 

Handtracking not working in Unity Editor, only in builds


I have tried searching and investigating a lot about this issue,

as far as i know is not unity settings related,

my teammate is using the same setup as me,
he is using the same project synced using GIT, and when he plays in the editor his hand tracking works,
and their hands are visible, but mine doesnt work,
im so exhausted of looking for solutions, i dont even know what to do i have tried the beta test channel in the oculus settings and other oculus headsets, i have tried quest 2, quest 3 and quest pro, and it doesnt work on my pc, can someone give me any idea on where to start looking to fix this issue?

is someone with the same problem as me?

im not using OpenXR, just the Meta All in one SDK, and the building blocks, using link with cable

All, and even tried the public test channel also, also i have developer mode on the headset




Using the building blocks in scene, dropped Camera rig, and hand tracking, made sure hands are well setup with left and right enuns, in the oculus settings, i set these


Also in unity i set the Oculus loader , and passed project validation



So in short my current status is:
Headsets are in Developer mode
Oculus PC App Developer Runtime Features: Enabled
Connected through Link
Unity 2022.3.17f1
Using Meta All in one SDK v60
 - Processor: 12th Gen Intel Core i9-12900k
 - Graphics card: NVIDIA GeForce RTX 3600
 - Ram: 32 GB
 - Windows 11

Hand tracking doesnt work in editor, but does work in builds, this is making my developmentiteration speed so slow. please i dont know what to check now, for all my teammates the hand tracking is working in editor but not for me


Honored Guest

Hi @Extrys, these steps might help:

  1. Ensure that under ProjectSettings -> XR Plugin Management -> "Oculus" is selected.
  2. From the menu, select Oculus -> Tools -> Project Setup Tool and then select "Apply All" from the recommended settings. 

Can you let me know if that solved it for you? It seems like you're not the only one that reported this. Also recommend following all of the steps here:

Honored Guest

I had a completely same problem as you, but I solved this problem according to this article.

How about trying it?