cancel
Showing results for 
Search instead for 
Did you mean: 

Have trouble with importing Meta All-in-One SDK from Unity Package Manager

YY_nb
Explorer

Meta has released the new Meta XR All-in-One SDK v59 in the Unity Asset Store in recent days, and Oculus Integration has deprecated. However, when I install it from Unity Package Manager, there is an error log in the console indicating that "[Package Manager Window] Cannot perform upm operation: undefined == true [UpmError_NotFound]. UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()". Therefore, I can't successfully import Meta XR All-in-One SDK to my Unity. It is very strange. I tried Unity 2021.3.29, 2022.3.1, but it still can't work. Does anyone meet this problem?

YY_nb_0-1699875641147.png

 

25 REPLIES 25

PG13park
Honored Guest

Hasn't been working for me either

Light.Matches
Honored Guest

I got it working. I don't know what changed and it doesn't make sense to me so this might be next to useless but I'll briefly list some ideas/things I tried.

It's possible Meta or Unity fixed something on their end so I encourage everyone to just try again. Other ideas: In another forum, someone said they logged in and out of Unity, and deleted any Meta-XR folders in their project's library/PackageCache/, that worked for them. I also disabled and reenabled my firewalls as suggested by @zeroonedeveloper. Disabling didn't immediately fix the problem but I had to give permission to various apps to bypass the firewall (or whatever the exact Windows prompt message is). I was too stupid and tired to note which apps requested permission, sorry! That's really all I can think of. 

Great work Light.Matches

I have a new bug with the Meta XR All-in-One SDK which I've reported a few places. If you switch form controllers to hands you can't switch back from hands to controllers 😞

I think this is also new, where I could easily log this bug

https://developer.oculus.com/downloads/package/oculus-developer-hub-win

Hi, have you solved your problem? I can't import Meta All-in-One SDK through name either.

Light.Matches had some success with the methods outlined above.

Mine worked straight away so I don't have any more ideas than those above 

 

neocao123
Honored Guest

Well, Still not working with all ways tested as I could do. 

Have you tried grabbing from the Asset Store (clutching at straws here I know)

https://assetstore.unity.com/packages/tools/integration/meta-xr-all-in-one-sdk-269657

wangdinglu
Honored Guest

I meet same problem and have tried all method metioned above. Is there any solution? 

Hey wangdinglu

I think you'll have to log a bug with Unity. I think they may be the ones who create the actual packages instead of Meta. They are pretty quick to respond from recent experience and you can log the bug through the editor. Create a simple test project first that you log the bug through so it doesn't take ages to zip up and send the scene to them (all automatic with the bug report) https://unity.com/releases/editor/qa/bug-reporting

 

tzx.6667.2023
Honored Guest

hi, have anyone sloved the problem? i also meet same problem at 2022.3.13f1c1