Showing results for 
Search instead for 
Did you mean: 

Have trouble with importing Meta All-in-One SDK from Unity Package Manager


Meta has released the new Meta XR All-in-One SDK v59 in the Unity Asset Store in recent days, and Oculus Integration has deprecated. However, when I install it from Unity Package Manager, there is an error log in the console indicating that "[Package Manager Window] Cannot perform upm operation: undefined == true [UpmError_NotFound]. UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()". Therefore, I can't successfully import Meta XR All-in-One SDK to my Unity. It is very strange. I tried Unity 2021.3.29, 2022.3.1, but it still can't work. Does anyone meet this problem?




Honored Guest

I know it’s not the answer you are after but I have had no issues with importing. I tried with the latest release of Unity and the latest LTS. Is it possible it’s something that something else is impacting your editor interface? Can you import something else as a test? It just looks to me that the error you are seeing is more to do with Unity and the Packager Manager window not playing nice together.

It is strange that I can import other packages, but I can't import Meta XR All-in-One SDK .

Honored Guest

Exactly same problem on Unity 2021.3.32f1c1 and 2021.3.26f1c1, haven't solved yet.

Hey I got it working with Unity 2021.3.30 using the Package Manager.

Add package by name  com.meta.xr.sdk.all



That makes so much sense now. Not why it happened for you, I am still not sure why.

Adding it via the name method was good thinking!

Honored Guest

I'm having the exact same issue. Importing by name didn't work. I tried importing only the core that also doesn't work. Let me know if a solution is found.

Hey Light.Matches

Could there be a firewall or some anti virus protection blocking the package manager at your end?

I appreciate the prompt reply. I don't think it can be because I'm still able to import the now deprecated Oculus Integration package 57.0.1

Import or
Download & import
the old package

If you've got the unity package changed on disk then it won't need to download it.
May be worth trying an old asset store asset you've bought that needs to be downloaded again. Completely rule out a firewall issue