cancel
Showing results for 
Search instead for 
Did you mean: 

Keyboard Overlay broken with v33 update

Pascal-Teooh
Explorer

The Keyboard overlay doesn't come up any more after the v33 OS update. Is this something the needs fixing in a system update or are there some new settings/manifest entries that are needed from this version?

46 REPLIES 46

None of those seem to work, no keyboard appears regardless of which option for the keyboard we pass. Do we need a specific SDK version? We are also using Unity 2020.3.10f1

DanRaySN
Explorer

Do you think you can update your Oculus SDK V34 in your current project? Also yes, It is working on Unity 2020.3 LTS version.

 

Make sure on your OVRCameraRig on Quest Features under General Tab, you enabled the Require System Keyboard.  https://developer.oculus.com/documentation/unity/unity-keyboard-overlay/

 

If you are not familiar with TouchScreenKeyboard, see the reference: 

https://docs.unity3d.com/ScriptReference/TouchScreenKeyboard.Open.html

 

For you to confirm that this code is working, try and test it on your android mobile devices. 

You can call the function when you select InputField. e.g. 
public void EnabledOverlayASCIICapable()
{

keyboard = TouchScreenKeyboard.Open("", TouchScreenKeyboardType.ASCIICapable);

}

Once you select the InputField/Button and trigger an event to call your Function. 

Test on your InputField, Add an Event Trigger or create a function that will call the function to enable your keyboard overlay when your InputField is .onSelect(); 



We have an event system enabling the keyboard onSelect for the input field, and it still doesn't work (we have had this system for over a year and everything was working before v33). I can see it working once after restarting the headset (works once) and I See the different options keyboards (ASCII, phonepad, regular). I also updated to v34 of the SDK and still broken. We are using the TMP_InputField but that shouldn't make a difference since for opening the keyboard we are just opening OnSelect which is triggered. Another thing that happens is that after the keyboard is closed the app doesn't get back focus so the controllers are not present and the only option is to quit the application.

Hi Ayfel, 

 

Are you using other VR plugins like the XR Interaction toolkit, etc.?

 

Please refer to the link 

https://www.youtube.com/watch?v=Y6a3AUoUfiE

 

using Unity Engine 2020.3 LTS 
Oculus SDK v34
Oculus updated system v35 

 

The Trigger Event is much the same behavior with using Inputfield. We also tested it and it works. 

 

Thanks

 

 

No luck with sdk 34, we use our own implementations and no interaction toolkit or anything alike, and like I mentioned it has worked for over a year until these updates so I am not sure what could be different now.

drod7425
Explorer

I made identical bare bones projects targeting both Android and Oculus Quest 2 that just tests the TouchScreenKeyboard.Open call without anything else in the scene. The only difference is the standard Unity camera vs OculusCameraRig. I can confirm that TouchScreenKeyboard.Open displays the keyboard as expected on Android, but not Oculus.

 

 

using UnityEngine;

public class KeyboardTest : MonoBehaviour
{
    TouchScreenKeyboard keyboard;
    private void Start()
    {
        keyboard = TouchScreenKeyboard.Open("Keyboard", TouchScreenKeyboardType.ASCIICapable);
    }
}

 

 

Unity 2020.3.10

Platform SDK 35.0

Version 35.0.0.117.341.334653283

Runtime Version 35.0.0.118.341.334652914

 

AndroidAndroidOculus Quest 2Oculus Quest 2

Hi, Drod

 

Have you solve the issue? 

 

Are you using a OVRCameraRig on Quest? 

Enable system keyboard from Unity 

Enable Keyboard Overlay | Oculus Developers

OVRManager surfaces the keyboard overlay project setting to easily display the system keyboard as an overlay on your app.

  1. Enable focus awareness.
  2. From the Hierarchy view, select OVRCameraRig to open settings in the Inspector view.
  3. Under OVR Manager, in the Quest Features section, select Require System Keyboard.

I tried to redo again a process with another project and with Quest1 headset with a V34 OS(not yet updated). 


I still did the same thing as I did before with a workaround and it is working just fine without any restart or issue with headset. 

Here is the video for the reference: Oculus Keyboard Overlay on Quest 1 - YouTube

Unity Engine 2020.3 

Oculus Integration SDK V35

Oculus Quest 1 OS V34

 

Does the app that you are working on is using another plugins? 

Unfortunately, I already had that option enabled. It does not solve the issue for me on Oculus Quest 2 v35.

Screenshot 2021-12-15 111201.png

The test app does not use any other plugins than the ones installed by the Oculus Integration package. I followed the instructions here in a blank 3D project. Once I had completed the guide, I simply added the above script to the OVRCameraRig and Built & Run.

Ayfel
Expert Protege

Any news please? This is definitely not working as expected, I am seeing tests from Drod with the same results and we are getting grilled by clients and dont know how to escalate this any more

drod7425
Explorer

Alright, so it seems that this is at least partially an issue with the version of Unity (2020.3.10) we were using. I checked the release notes and there are several changes and fixes related to TouchScreenKeyboard between 2020.3.15 and 2020.3.20. We updated to the latest LTS version (2020.3.25) and the keyboard is now working as expected.

 

Thanks to everyone for the support, especially @DanRaySN for some helpful back-and-forth.