cancel
Showing results for 
Search instead for 
Did you mean: 

MRUK couldn't load any scene data.

saibo713
Explorer

After i update the headset system to V65,I find I can't load scene data using MRUK. I tried the building block room mesh and the scene was successfully loaded, so it's not a linking problem. The warning message:


MRUK couldn't load any scene data. Scene capture does not work over Link or XR Sim.
If using Link please capture a scene with the HMD in standalone mode, then access the scene model over Link.
If a scene model has already been captured, make sure the spatial data feature has been enabled in Meta Quest Link (Settings > Beta > Spatial Data over Meta Quest Link).
If using XR Sim, make sure you have a synthetic environment loaded that has scene data associated with it.
UnityEngine.Debug:LogWarning (object)
Meta.XR.MRUtilityKit.MRUK/<LoadSceneFromDevice>d__60:MoveNext () (at Library/PackageCache/com.meta.xr.mrutilitykit@65.0.0/Core/Scripts/MRUK.cs:576)
System.Runtime.CompilerServices.AsyncTaskMethodBuilder`1<Meta.XR.MRUtilityKit.MRUK/LoadDeviceResult>:Start<Meta.XR.MRUtilityKit.MRUK/<LoadSceneFromDevice>d__60> (Meta.XR.MRUtilityKit.MRUK/<LoadSceneFromDevice>d__60&)
Meta.XR.MRUtilityKit.MRUK:LoadSceneFromDevice (OVRAnchor/FetchOptions,bool)
Meta.XR.MRUtilityKit.MRUK/<LoadSceneFromDevice>d__59:MoveNext () (at Library/PackageCache/com.meta.xr.mrutilitykit@65.0.0/Core/Scripts/MRUK.cs:552)
System.Runtime.CompilerServices.AsyncTaskMethodBuilder`1<Meta.XR.MRUtilityKit.MRUK/LoadDeviceResult>:Start<Meta.XR.MRUtilityKit.MRUK/<LoadSceneFromDevice>d__59> (Meta.XR.MRUtilityKit.MRUK/<LoadSceneFromDevice>d__59&)
Meta.XR.MRUtilityKit.MRUK:LoadSceneFromDevice (bool)
Meta.XR.MRUtilityKit.MRUK/<LoadScene>d__56:MoveNext () (at Library/PackageCache/com.meta.xr.mrutilitykit@65.0.0/Core/Scripts/MRUK.cs:461)
System.Runtime.CompilerServices.AsyncTaskMethodBuilder:Start<Meta.XR.MRUtilityKit.MRUK/<LoadScene>d__56> (Meta.XR.MRUtilityKit.MRUK/<LoadScene>d__56&)
Meta.XR.MRUtilityKit.MRUK:LoadScene (Meta.XR.MRUtilityKit.MRUK/SceneDataSource)
Meta.XR.MRUtilityKit.MRUK:Awake () (at Library/PackageCache/com.meta.xr.mrutilitykit@65.0.0/Core/Scripts/MRUK.cs:375)

Any thoughts or help would be greatly appreciated!

1 ACCEPTED SOLUTION

Accepted Solutions

saibo713
Explorer

I changed the MRUK package to v64 and the problem is solved. I don't know why...

View solution in original post

5 REPLIES 5

saibo713
Explorer

I changed the MRUK package to v64 and the problem is solved. I don't know why...

My guess is, that they changed the permissions for the MRUK in v65 to make it even harder for developers to develop in mixed reality and test it directly in Unity. Because why would you want to have it easy for developers, right, Meta? Don't want anybody to figure out how to access any of the camera data, right?

hahah 

Iknow, right. It's been almost a month. When will it be fixed?

It's not easy to go down because of the network function of version 65... I hope it's fixed quickly.