cancel
Showing results for 
Search instead for 
Did you mean: 

Meta XR Simulator - Left Hand does not receive controller button input

MajorDoMamutus
Honored Guest

Hi! 
I wanted to explore automated testing on our app. I was able to get the Meta XR Simulator up and running, including connection with IRL quest 3 and it's controllers. 

Here is my problem: no button/touch interaction on the Left controller is represented on the left hand, both using mouse&keyboard input in mXRsim, as well as input on connected IRL Quest controller. At the same time all of those inputs work correctly on the right hand, both from Right controller and from mouse&keyboard. (button/touch interactions = triggers, buttons, button touch surfaces, ect.)

Tracking on Left Hand (using IRL quest controller) works correctly.

To check if there is something wrong with our unity project I:
- tried similar interactions with WMR Mixed Reality Portal which has built in simulator - both hands button interactions are working
- tried installing mXRsim on old XR Interactions Toolkit (2.5.2) sample scene - same issue as in our project - Left hand button interactions do not work, right hand interacts with a scene just fine.

I do not see any errors in console indicating problems with input system.

I am using Unity 2022.3.14, OpenXR and Meta XR Simulator v65 installed via Package Manager.

0 REPLIES 0