cancel
Showing results for 
Search instead for 
Did you mean: 

OVR Plugin failure for detection space / importing Room-Data into Unity

Since you, @MetaQuestSupport, are clearly ignoring my post in the Unity VR Developer forum and my direct messages as well, I will ask this here again:

I want to use the Room-Setup feature from the Quest 3 in Unity in Mixed Reality.

I get an error for importing the transform-data for the gameobjects of the Quest 3-defined room in Unity. All of the walls and room objects are at (0,0,0) with no additional rotation and I get this error:

[OVRPlugin] [XRCMD][failure] [XR_ERROR_HANDLE_INVALID]: xrLocateSpace(*(XrSpace*)space, baseSpace, ToXrTime(GetTimeInSeconds()), &spaceLocation), arvr\projects\integrations\OVRPlugin\Src\Util\CompositorOpenXR.cpp:11831 (arvr\projects\integrations\OVRPlugin\Src\Util\CompositorOpenXR.h:302)

Error.jpg


It seems to be an issue that is unique to my PC, but I can not figure out why and where the issue is.
We tried the same scene and multiple other with the room model or the new MR Utility Kit in it, and we don't know what is different in my system.

We already tried uninstalling all of Unity, Meta and Oculus desktop and cleaning the registry / Appdata.

It works on different PCs with the same Headset, it also works on different PCs when I am logged in into Unity and Oculus Desktop.

We also switched out the Cable, the Headset and the USB-C port.

We also deactivated all of Windows Defender and disconnected the PC from the Web.

Everything needed in Unity is activated, as well as Developermode on the Quest and in Oculus Desktop. This should not be the issue, since the same project works on other PCs.

The Setup is:
13th Gen Intel(R) Core(TM) i9-13900K 3.00 GHz
32.0 GB DDR5
Nvidia RTX4090

Windows 10 Pro
Version 22H2
OS build 19045.3930

 

10 REPLIES 10

angad363
Honored Guest

I had installed Side Quest streaming (following a stupid tutorial as to how to deploy my app on Meta Quest 3) and I think so that has screwed up all of my work. I have uninstalled everything I could find relating to SideQuest but still am getting the same error.