Showing results for 
Search instead for 
Did you mean: 

OVRInput Button rift controllers gives no result (unity versions 2017 & 2018, OS Windows 10)

Not applicable
The input methods for the rift contoller buttons in unity (versions 2018.4.1f1, 2018.3.7f1, 2017.4.27f1) don't seem to work.
OVRInput.Get(OVRInput.Button.One) and similar give no result (or always "false") for any of the buttons be it right or left controller.
 Samlpe scenes provided in sample framework have also dead buttos. The avatar's finger poses don't change either, when fingers put on puttons or removed from them. I'm almost sure the poses worked last week, when I had the very first test run importing the Oculus Unity Integration. The oculus app updated two days ago - may this be causing the issue?
Has anyone same problems?
What might be a solution?
This ist the exceptional case, that I write in a forum. Usually I find all my answers by googling and reading. This time I failed permanently.
Any help appreciated. Thanks for replying kindly

Honored Guest

I also have issues with the touch controllers.

Simple scene with basic setup... OVRCameraRig, OVRManager and OVRInputModule...
World canvas with buttons and the controllers don't trigger OnClick events.
With Event Trigger on the button, i can get them to trigger (only) PointerEnter and PointerExit events.
I am currently using those events to check if i am pointing at the button and then in Update i wait for OVRInput.Get(OVRInput.Button.PrimaryIndexTrigger).

Surely this workaround isn't the proper way of doing this or is it? D 😄 

Have you figured where is the problem?

Not applicable
What I found out so far is: the controllers stay dead if you run your test, but don't cover the headset's inner sensor, the one that indicates "user's head is in the headset"
means that
OVRManager.HMDMounted ()
must have occured at least once, after start.
then the controllers are fully active and stay so even after HMDUnmounted occurs. Which is weird, but I'm ok with that. No need to put stickers on the sensor 🙂

This can not have been the actual issue. Since I had the headset on my head and covered the HMDMounted sensor etc.
Still no idea, what the bug actually was.
Last night the controllers and avatar's hands suddenly started to behave as they should. Buttons reacting, fingers moving.
I literally didn't change anything, compared to all my efforts over many days before. I even worked on in the same project and same scene, just using keyboard input (since controller buttons would be just a "nice to have" for my current setup)