Showing results for 
Search instead for 
Did you mean: 

Oculus Controllers not working [Solved]

Not applicable
I'm currently making a project using Unity on a Oculus Quest and I seem to be having problems with the controller inputs. I tried using the OVRInput.GetDown(OVRInput.Button.Three) as per Unity documentation and there seems to be a bug when I use the X and A inputs. Once the X and A Inputs are coded the Y and B inputs seem to be disregarded. I tried using different work around like messing around with the Android Manifest and still doesn't work. Is there any other work arounds with this? Thanks 

Unity Version 2019 2.7f2
Oculus Plugin: 1.38

Not applicable
Nevermind, I got mine working by copying the Android manifest file from the editor ""C: \ Program Files \ Unity \ Hub \ Editor \ (or the version you use) 2019.1.12f1 \ Editor \ Data \ PlaybackEngines \ AndroidPlayer \ Apk" to Assets / plugins / Android and added
  <uses-feature android:name="android.hardware.vr.headtracking" android:required="true" android:version="1" />
  <uses-feature android:glEsVersion="0x00030001" />

I think my main problem before was I copied it feom the oculus package and it was under a different name.