Showing results for 
Search instead for 
Did you mean: 

Oculus Unity Integration - v1.36 (04/23/19)

Retired Support

Version 1.36 of our integration for Unity has been released!

The Oculus Integration for Unity package adds scripts, prefabs, samples, and other resources to supplement Unity’s built-in support. The package includes an interface for controlling VR camera behavior, a first-person control prefab, a unified input API for controllers, advanced rendering features, object-grabbing and haptics scripts for Touch, debugging tools, and more. For more information, see our Unity Getting Started Guide.

You can grab the latest version of our Unity Integration here (through the Unity Asset Store):

More information, as well as general known issues with Unity, about this release can be found here.

1.36 Update Notes

New Features

  • The Oculus Integration for Unity (not including the Avatars components) has been updated to support ARM64 development.

Integration Changes

  • Updated the Oculus Unity Integration to 1.36, including:
    • Updated the Avatars integration to 1.36
    • Updated the Platform integration to 1.36
    • Updated the Audio integration to 1.36
    • Updated the LipSync integration to 1.36

Bug Fixes

  • Fixed an issue where OVRPlugin.systemDisplayFrequenciesAvailable returned an empty array when using a IL2CPP backend.
  • Updates to reduce controller pose latency.
  • Fixed an issue in Mixed Reality Capture where the virtual world rendered a few frames behind the real world when the user’s headset is moving.

API Updates

  • Deprecated the OVRBoundary.SetLookAndFeel() and OVRBoundary.ResetLookAndFeel() APIs.

Known Issues

    All Unity 2018.2 versions

    • (Mobile) You'll need to either switch the AndroidBuildSystem to internal or export a Gradle project and modify the SigningConfig in the build.gradle file to include v1SigningEnabled=true, v2SigningEnabled=false.


    • (Mobile) Some game objects may appear darker when loaded in 2018.2.20f1. To work around this issue, load the project in another version of Unity, like 2018.2.19.
    The thread for the previous version (v1.35) can be found here:
    17 REPLIES 17

    Expert Protege
    Kinda hard to not notice that this release also added the new Rift S / Quest Touch controllers...



    Looks good, but I'm getting immediate crashes on load of my Go app which was working great on 1.35.
    Where can I find 1.35 to downgrade? It's not available here, nor on the Legacy Unity Release Archive page.

    Retired Support
    @timothyallan Could you submit this as a bug report? Please include any logs and screenshots of the errors you're getting:

    I'm assuming that's a no.
    This is an expensive lesson, as I usually don't commit 3rd party packages to source control, but looks like I'll have to start!
    Thanks anyways.

    I had the same issue as you mentioned, where with the latest oculus integration package my app was crashing on the Oculus Go right on launch (while it worked fine with older oculus integration package before).
    When i saw your post mentioned the same, i then removed the Oculus (integration) folder from the assets and downloaded the last Oculus Utilities package from the downloads page. Not ideal as that one is a good bit older of course, so not on the latest feature level, but at least that way i could run my app on the Oculus Go again for the meantime until this issue is fixed.

    FWIW, I've assembled/kept an archive of older Integration packages. Send me a PM if you're interested.

    thanks @MikeSwanson, but at least i'm good now.
    I did some further tests and got it working with the Oculus integration 1.36 on the Go now in my game.
    First i just imported the Oculus integration (1.3.6) package into a blank project in U2018.3.4F1 and then again in U2019.1F2 and deployed those with just a cube in the scene and the app set to vr support enabled, just to see if that by itself already triggered any errors.
    And no, was all good, ran on the Oculus Go no problem.

    Then in my actual game (where it was crashing on the Oculus Go with oculus integration 1.3.6) i closed the unity editor, removed anything with Oculus, OVR etc, so anything related to Oculus from the project assets and then downloaded the 1.3.6 Oculus integration fresh again.
    Then when i tried a deploy then it did not crash anymore on the Oculus Go, but it did take way longer to load than before i had added Oculus Integration to the project.

    So i think in my case the main two issues were a) that i had older Oculus Utilities /Integration version stuff in my project which was likely not playing well with the things from the latest plugin version and b) the Oculus Integration adds way more in filesize/mem usage to the project than my old smaller utilities which is no good for load times and if your app already uses a bunch of memory, too on the mobile devices.

    I have now removed all from the Oculus integration package's assets which i don't need for this project and only kept what i need/use, because then it uses way less filesize etc and the load time is shorter again.

    We ended up having to make a new project with only 1.3.6 and then slowly import everything from the original 1.3.5 project. We're still doing it, and have also noticed way longer load times initially, as well as between scenes.
    Had a client comment on it as well already on a beta build, which is never a good thing.

    yeah, you can check whether you need things from Oculus Integration in your project or are fine with the older Oculus Utilities if you don't and want smaller filesize automatically.
    If you want to use the Oculus Integration (which could make sense since it actually does have some cool improvements and additions), you best check the build report after doing a build so you can see what all is added to the build and compress more or remove the biggest offenders.
    (You can see the build report in the Unity editor log after doing a build)