Showing results for 
Search instead for 
Did you mean: 

Oculus Unity Integration - v1.42 (10/23/19)

Retired Support

Version 1.42 of our integration for Unity has been released!

The Oculus Integration for Unity package adds scripts, prefabs, samples, and other resources to supplement Unity’s built-in support. The package includes an interface for controlling VR camera behavior, a first-person control prefab, a unified input API for controllers, advanced rendering features, object-grabbing and haptics scripts for Touch, debugging tools, and more. For more information, see our Unity Getting Started Guide.
You can grab the latest version of our Unity Integration here (through the Unity Asset Store):
More information, as well as general known issues with Unity, about this release can be found here.

New Features

  • 1.42 is a maintenance release. There are no new features in this release.

Integration Changes

  • Updated the Oculus Unity Integration to 1.42, including:
    • Updated the Audio Spatializer to 1.42
    • Updated the LipSync integration to 1.42
    • Updated the Platform integration to 1.42
    • Updated the Avatar integration to 1.42

Importing the latest Oculus Integration

When importing a new version of the Oculus Integration into an existing project, follow the steps on Importing the Oculus Utilities Package to ensure a smooth upgrade experience.

Known Issues

Please read the release notes in their entirety here:

Legacy Unity Release Archive

Legacy versions of the Unity Integration can be found in the Unity Integration Archive.

The thread for the previous version (v1.41) can be found here:

Level 4
Why doesn't Teleport work?
Why do the custom hands still glitch?
Why do the avatargrab demo hands not work?

Is anyone testing this before its rolled out?

I've been pretty patient watching this evolve and I teach a lot of these things, but this is a sad SDk for unity compared to vive.

Steps to reproduce.
1. Open the demo in usage: Add your avatar ID. Build project, no hands show up on the grab avatar. I even wiped out the manifest(which Why should I have to do this?)
2. repeat for each.

Level 3
I believe that the Unity SceneManager.LoadScene("SceneName"); is broken on the Quest, and has not worked in the last few versions of the integration. it works fine on the Go.

 I am starting to do more Quest work, and I have been able to get by with building everything in a single scene, but would like to be able to organize my app by scenes. Has anyone else had a problem loading scenes on the Quest?

Level 2
I'm experiencing the AvatarGrab scene issue as well, with no hands showing up.  I can still grab the blocks by imagining where my hands would be and using the side trigger.  So something is working, there's just no hand model attached.

Not applicable
Still no news ? Teleportation scene is broken , same for avatar grab.

Level 2
Hello everyone,
Is it necessary to import all "unity integrations" to make a project for Oculus Quest?
I have check only VR and got several errors and warnings, i dont need "Sample Framework" or "Avatar", for example. Then if i uncheck to import all needed packages, then im not able to compile and run.  



Level 3
If you update to SDK Version 12 Locomotion is FINALLY working!!!! 😉