cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Utilities for Unity 5.x Mobile Documentation outdated. How do I start?

Brainlogin
Level 4
I am trying to get started with developing for the VR Gear using Unity 5 and the Oculus mobile SDK 1.0.



Following the Oculus Documentation doesn't help because it says:


 
Project Settings (mobile only)


 
The mobile Utilities package includes a Project Settings folder which provides default settings for a VR mobile application. You may manually copy these files to your [Project]/Assets/ProjectSettings folder.



However, there is no such thing as "mobile Utilities package" under the Downloads, there is only Utilities for Unity 5. And this doesn't contain a ProjectSettings folder, and has many mobile specific assets missing (eg. the signature file placeholder 'assets' within Android).



I assume the documentation is outdated and refers to earlier package versions. What is the current way to get started with mobile VR development or get some samples work for Unity 5?



What I've tried: After importing Utilities, I've tried importing any of the existing example versions.


1. importing the VRsamples located in the OVR mobile SDK, but this gives a Unity 4.6 required error.


2. importing the currently separately downloaded Utilities for Unity 5 - SDK examples, but when I replace the Project Settings manually as described in the manual, this results in 'could not load ovrp symbol ... symbol not found' errors.



Is this a Mac-related error (I'm on Osx Yosemite, I've installed Oculus Runtime for OSX too)?
 Or is there some other package I'm missing?



Thanks
10 REPLIES 10

leftler
Level 4
You should probably asking this over at the Unity development section of this forum, not the community section
 forum.

https://forums.oculus.com/developer/categories/unity

cybereality
Level 15
Thanks @leftler . I'll move to the Unity section.

@krisventure The Utilities should work for both PC and mobile. The mobile SDK is for Unity 4 and should not be used with Unity 5, or combined with the Oculus Unity Utilities. For the signature file, you can create the folder yourself and place your oculus sig in there. That's normal. Not sure about the project settings,

Honestly, I'm not too familiar with mobile VR development, but maybe someone in the community can assist.

Brainlogin
Level 4
Okay thanks. I wasn't sure because clearly, there are instructions on the mobile VR inside the Utilities for Unity 5 description so I took it there must be Unity 5 support.

I was more concerned about the missing Project Settings folder in the utilities as their description pointed to that.

vidonme
Level 2
@krisventure 
I developped a mobile vr app using unity5 and oculus utilities and I did nothing about "That project settings folder". Just place your signature file in right place and check "virtual reality supported".

Brainlogin
Level 4
@vidonme thank you for your reply, I'll try that way.
So basically if I understand well, to get the examples working, I just import the Utilities for Unity 5, copy my sig file , set the build settings and the player settings and then import the utility SDK examples and it should work. I'll give it a try and keep this thread posted.

vidonme
Level 2
@KrisResource 
yes. Import utilities and check 
"virtual reality supported" in PlayerSettings->Other settings and place your sig file in Assets\Plugins\Android\assets

vidonme
Level 2
@krisventure 
yes. Import utilities and check "virtual reality supported" in PlayerSettings->Other settings and place your sig file in Assets\Plugins\Android\assets

Brainlogin
Level 4
@vidonme 
Thanks again for replying. Just to be sure we're on the same settings, I'm working on OSx and using Oculus mobile SDK 1.0.0.1. I read VR Gear apps will be required to use SDK 1.0> so I want to start with that.

Now In my case there are many errors and warnings, just upon setting up things the way we've discussed above:

1. As soon as I turn virtual reality supported ON, and then restart Unity, it gives 3 errors:

Could not load symbol ovrp_GetEyeOcclusionMesh : dlsym(0x11a48dc10, ovrp_GetEyeOcclusionMesh): symbol not found
Could not load symbol ovrp_GetAudioOutId : dlsym(0x11a48dc10, ovrp_GetAudioOutId): symbol not found
Could not load symbol ovrp_GetAudioInId : dlsym(0x11a48dc10, ovrp_GetAudioInId): symbol not found

2. Then if I go ahead and add a scene and then in Build settings I press 'Add open scenes', and Build and Run, I'll get warnings like:

Failed to create Oculus HMD.
Compositor failed to initialize.
Bad config or LibOVR not found. VR disabled.
Oculus HMD not present. VRSettings.enabled set to false.

Are those things due to some settings that I should change or is it something you've never seen?

vidonme
Level 2
I am working on Windows and build an app for Oculus store. I did nothing about Oculus mobile SDK, because I am using Unity5.3.1 (Unity is already integrated with Oculus SDK).