cancel
Showing results for 
Search instead for 
Did you mean: 

OpenXR / XR Interaction Toolkit app not launching

jtriveri
Expert Protege

I want to leverage Unity's cross platform ARFoundation library which requires using the Unity OpenXR Plugin rather than Meta's own XR Plugin.

I have set up several valid OpenXR skeleton projects inside of different versions of Unity but all builds will not launch on Quest unless I use OpenGLES3.2. I unfortunately must use Vulkan for my project's needs. Builds with other versions of OpenGL will not launch properly unless I sleep and wake the device, and Vulkan builds will simply crash. A crashing Vulkan build's logs are attached to this post.

I have tried multiple versions of Unity (2021, 2022.3.11, 2022.3.15, and 2023.2.3) and multiple separate projects with no success. I correctly configure the Unity OpenXR XR Plugin with the Meta Quest Feature Group and correct controller interaction profiles.

3 REPLIES 3

TsFreddie
Honored Guest

All of our projects are crashing today with the same error as yours. Either Unity's OpenXR or Meta system update broke OpenXR Vulkan Development Build. My money's on the System Update since our apps were running fine two weeks ago and last OpenXR update was in October.

Btw, try building a release build (without Development Build enabled in the build settings). Release build worked once for us in an empty project, but we haven't had time to try our bigger projects to verify.

v59 made silent breaking changes to the way shared anchors work. v60 seemingly screws up Unity OpenXR builds. Meta please…

omixlab
Explorer

I was able to get around this issue by switching from OpenXR to Oculus plugin. Will switch back when it's fixed. Right now I'm happy because I can finally do some useful debugging and it also works with RenderDoc again.