Showing results for 
Search instead for 
Did you mean: 

Quest project builds and runs, but stays stuck on 3 dot loading screen

Honored Guest
I followed the official instructions for setting up Unity for Quest development.

I tried to build using the included example scenes. The build works fine, but when it runs on the quest, it stays stuck on the animated 3 dot loading screen.

The ADB logs show no errors, and even show various Unity logs while stuck, such as the focus gained and lost events. So I'm pretty confident that the build is running, just stuck behind the loading screen.

I've tried from scratch several times, factory reset my Quest, messed with all sorts of build settings, but can't make any progress.

I've attached the compiled APK in case that helps, and the full ADB logs.

Any suggestions?

Running on Unity 2019.2.21


Any progress on this?
I am dealing with the same issue.

Honored Guest

Are you using by any chance Unity Cloud Build? I had that same issues from any builds originating from Cloud Build.

I could build it locally, and the game would work perfectly.


@MadeinBrooklynGames - (the orig post is very old)


I had similar problems in the past - for me, the VR system wasn't being initialized. Assuming you are using a recent version of Unity, the Oculus Integration package and the Unity XR Plug-In Management system, check the following:


1) The XR Plugin Management has been installed, and the Oculus plugin activated

2) "Initialize XR On Startup" is checked

3) Confirm that you have removed the defaul main camera, and replaced it with an instance of the "OVRCameraRig" prefab.

4) If you arent using the Oculus Integration package, make sure the you have converted your default main camera to an XR Rig (right click it -> XR -> "Convert Main Camera to XR Rig" (which adds a "XRRig" script to it)


Hope some of this solves your issue.


Unfortunately this didn't work for me. I have "Initialize XR on startup" checked for all systems, but whenever I made a "dev" build (seems to work fine with normal builds) I get stuck on the 3 dots still


So it turns out that for me, this issue would only happen in OpenXR dev builds (release builds worked fine). So I just ended up switching back to the Oculus XR provider and it seems to work again.

Honored Guest

If you figure out how to make a OpenXR dev build let me know!