Showing results for 
Search instead for 
Did you mean: 

Quests hands tracking is not working in Unity editor


For some reason hands tracking is not working anymore in Unity editor.

Tried with Quest Link and with Air Link.
Tried in a clean project with the latest updates and Quest Pro.
Tried in some old project for Quest 2 (and with Quest 2) where everything was fine a few month ago. Nothing.
Checked with Oculus Integration examples - controller ok, hands are absent in the editor.
In latest Unity Movement examples eye & face tracking works, controllers works, but no hands tracking, no head movement mirroring, no hands mirroring even with the controllers in the scene.
And of course I tried to reboot everything.

No errors in editor, but some warnings appear (only sometimes):

I will be grateful for any help. 

Windows 11
Unity 2021.3.4/2021.3.13
Oculus Integration v46
Oculus XR 3.2.2-pre.1
Oculus app version ( I tried latest Oculus app, then switched to test channel - no changes.
Quest Pro v46.0.0.226


Community Manager
Community Manager

Hey there! We see your having issues with your hand tracking through Unity Editor and want to get you to the right place so we can get you back on track! We want to make sure you're receiving the best information and troubleshooting steps to get you back in the VR universe. Which is why we want to invite you to post in our Developer Forums where our spectacular community can provide you with information and provide you with the steps needed! 


Please click here to get to our Developer Forums! We can't wait to get you back on track to enjoying your VR device!  

Thanks but this post is already on the developers forum or did I miss something?..



Honored Guest

Hi @DanceM - we're encountering the exact same issue. A few things we've learned:


Building an APK for MovementAura scene seems to work. Make sure your OVRCameraRig has "Permissions Requests on Startup" checked for Face Tracking and Eye Tracking.

Screenshot 2022-11-14.png


However, even a Windows PC build seems to have the same issues as in the Unity Editor where nothing is tracked (not the headset, not the controllers, not the hands). Facetracking & Eyetracking actually work in the Unity Editor (with no positional tracking of anything), but in the PC build, nothing works at all.


Additionally, in the PC Build and the Unity Editor, we're having the visual issue in the picture below (note, issues are in the Right Eye only - Left Eye is fine). This issue doesn't appear in the APK run directly on Quest Pro.


2022_11_14_HMD_Right Eye.jpg

@MetaQuestSupportany help would be appreciated on this!

Glad to hear that I am not alone in this, @ArdensWake 

All permissions were set in the project, in Oculus app, and experimental functions were enabled as well.

To fix this visual issue switch from Single Pass rendering to Multi-pass in Oculus XR setting for PC, then it will looks fine in the editor. But yeah, something wrong the with camera settings, it doesn't clear buffer for right eye.

Expert Protege

I couldn't get things working right for Quest Pro using Unity 2021. I had to move to Unity 2022.1. See my post

Honored Guest

I have the exact same errors, Im developing for quest2 and all my projects suddenly stopped showing hands in unity editor while using oculus link. Even new projects have the same problem.

I noticed that the skinned mesh renderer is disabled when in play mode for some reason and also I can still turn my palms towards me and access the oculus menu but still the hands dont show. The hand tracking works fine while in oculus home not connected to pc..

Meta really needs to get their **bleep** together with these updates

Unfortunately project upgrade to Unity 2022 did not change anything.


It is a bit out of date, so only works with unity 2020