Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Scene Understanding not working with quest 3 using link and Unity



I am trying to run one of the scene understanding examples (BouncingBall, oculus integration). When I build and run the project on the quest 3 standalone, everything works as expected (the ball is bouncing through my room). My problem is that running it via link from my PC using unity, it does not work. I am getting the following messages:

There is no scene model available, and scene capture cannot be invoked over Link. Please capture a scene with the HMD in standalone mode, then access the scene model over Link. If a scene model has already been captured, make sure the HMD is connected via Link and that it is donned.

I have captured a scene within the HMD in standalone mode and applied objects (furniture) to it. In the OVR Manager, I have enabled Scene support and Experimental Features. Oculus App has turned on the feature "share point cloud over oculus link". Also restarted the quest 3, oculus App and unity. Still the same problem.

When I use the spatialAnchor example, again, it works perfectly fine on the quest 3 standalone. When I use link with unity, I can save anchors, but when I load the anchors after reentering play mode, it does not work and I get the following message:

756b8795-d436-e18b-d2b6-94841ad6a441: locatable enabled? False changePending? False

So maybe this might be due to a missing scene model as well? Has anyone encountered similar problems? Since I am relatively new to oculus and unity, I would be really thankful if anyone could give some feedback.

Thank you πŸ™‚

Kind regards,


Honored Guest

Is your desktop Oculus application logged in to the same account you're using for everything else?


EDIT - And in the headset, did you enable Settings - Privacy - Device Permissions - Share Point Cloud Data?

Hey, thanks for your response. I am using the same account for the quest 3 and desktop Oculus application. My unity account is a different one, but this should not be a problem, right? Share Point Cloud Data is enabled on the quest 3 and on the desktop application.
I actually do not get the messages anymore (not sure why). So I believe the model is loaded. But it is still not working (the ball is not bouncing off my walls/furniture). Right now I get the following message in the console, when I enter play mode of unity:

[OVRPlugin] [QuerySpaces] inputs to xrQuerySpacesFB: actionQuery.filter == nullptr?: 0, actionQuery.queryAction: 0

This is happening when the model is being loaded in the OVRSceneModelLoader.cs Script. I checked the size of the anchors in the LoadSceneModel() function in the OVRSceneManager.cs script. The size of the anchors is zero. So I believe the anchor positions of my scene captured with the quest are not properly send to unity.

Might this be the case? Any ideas how to fix this?

Thanks a lot!

When you set up the project in the Meta development console, did you create separate applications for the stand-alone (Quest) and desktop (Rift) versions? Both application version ID's need to be entered in the Unity editor under Oculus - Platform - Edit Settings

You must have a separate application ID for the desktop version, created as a "Rift" application here...

The relevant documentation page for that seems to have gone missing, I think originally you could link to it from here under "Prerequisites" with the "Set Up Project Environment" link, but that appears to be broken.

Thanks for your response. I have now created two different application. One "Meta Quest (App Lab)" and one "Rift" app. I looked up the applications IDs in the API tap (there are several IDs, e.g. Federated AppID, App Credentials, ...). I copied the App-ID from the quest app and rift app to Oculus Platform Settings in unity. The ocululs desktop App as well as the quest 3 are all signed into the same account. Its the same account I also created the applications and its unique ids with. Share point cloud data is enabled on quest 3 and desktop application. Passthrough, Scene Support and Shared Spatial Anchor Support are all enabled in OVR Manager script in unity. I am using unity 2022.3.11 (also tried it on 2022.3.7) and ocululs integration v57.0.

I still encounter the same issue. When I connect the quest 3 with oculus link and enter play mode in unity, everything works except the ball is not bouncing off the walls (falls into infinity). When I delete my room setup on the quest, I get the error that there is no scene model available and the application does not start (when entering play mode in unity). Once I recreate the room model, the application starts, but the ball is not bouncing of the walls. I get the following message in the unity console that might be related to my problem?

[OVRPlugin] [QuerySpaces] inputs to xrQuerySpacesFB: actionQuery.filter == nullptr?: 0, actionQuery.queryAction: 0

Deploying the app standalone to the quest, everything works (ball is bouncing off the walls).
Am I missing something?

Thank you very much πŸ™‚

Honored Guest

For me, it does work with link but not after i build and run it on quest3.
So weird

Hi, did you ever solve the issue? I am having the same problem right now over Link. Thanks