Showing results for 
Search instead for 
Did you mean: 

Spatializer error with new projects

Level 2
When I import Oculus Integration and then import Oculus via XR Management in a new 2020.2 project I get the following error:

GUID [a57801270cf689244b48012cf9db1713] for asset 'Packages/com.unity.xr.oculus/Runtime/Android/arm64/' conflicts with:
  'Assets/Oculus/Spatializer/Plugins/Android/libs/arm64-v8a/' (current owner)
We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored.

Think this is a bug that needs to be solved, so we don't have to pick one of the files and delete the other. 

Level 2
Yeah, I'm also having this issue. I'm not sure if I'm doing something wrong or if it's a bug.

Level 2
any news about this?

Level 4
Same problem here.

Level 2

This is an issue with 2019.4.18f1 as well. 

Level 2

Guys i had the same problem but with photon and SDK. Some bugged things need some times reinstall 

Level 2

I had the same issue in 2020.1.17f1. I installed the oculus integration then installed Oculus via XR plugin management. I deleted the Oculus folder within Assets and then reinstalled Oculus Integration via package manager and all is fixed. Hope that helps. 

Great idea - I tried to action it but I got an error message "Some assets could not be deleted. Make sure nothing is keeping a hook on them, like a loaded DLL for example". I hadn't built anything into the scene yet and had minimal interaction (I installed XR Plugin management, deleted Vulkan drivers [live short and prosper], and nothing more that I remember). Creating a new scene and deleting the old Sample Scene didn't allow me to delete the folder. I'm using