cancel
Showing results for 
Search instead for 
Did you mean: 

Step 4. Import Meta XR All-in-One SDK from the Unity Asset Store

aberbotimue
Explorer

Hey all, 

I haven't even got out of the starting blocks.. 

technically I have fallen at the 4th hurdle, going through the hello world tutorial

https://developer.oculus.com/documentation/unity/unity-tutorial-hello-vr/

and when i try to "install" the Meta XR All-in-One SDK package i get this

 

[Package Manager Window] Error adding package: com.meta.xr.sdk.all@64.0.0.
Unable to add package [com.meta.xr.sdk.all@64.0.0]:
  One or more dependencies could not be added to the local file system:
    com.meta.xr.mrutilitykit: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.mrutilitykit/-/com.meta.xr.mrutilitykit-64.0.0.tgz' was denied
    com.meta.xr.sdk.audio: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.audio/-/com.meta.xr.sdk.audio-64.0.0.tgz' was denied
    com.meta.xr.sdk.haptics: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.haptics/-/com.meta.xr.sdk.haptics-64.0.0.tgz' was denied
    com.meta.xr.sdk.interaction: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.interaction/-/com.meta.xr.sdk.interaction-64.0.0.tgz' was denied
    com.meta.xr.sdk.interaction.ovr: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.interaction.ovr/-/com.meta.xr.sdk.interaction.ovr-64.0.0.tgz' was denied
    com.meta.xr.sdk.platform: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.platform/-/com.meta.xr.sdk.platform-64.0.0.tgz' was denied
    com.meta.xr.sdk.voice: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.voice/-/com.meta.xr.sdk.voice-64.0.0.tgz' was denied
    com.meta.xr.sdk.voice.composer: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.voice.composer/-/com.meta.xr.sdk.voice.composer-64.0.0.tgz' was denied
    com.meta.xr.sdk.voice.dictation: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.voice.dictation/-/com.meta.xr.sdk.voice.dictation-64.0.0.tgz' was denied
    com.meta.xr.sdk.voice.telemetry: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.sdk.voice.telemetry/-/com.meta.xr.sdk.voice.telemetry-64.0.0.tgz' was denied
    com.meta.xr.simulator: Cannot download the package. Your account does not grant permission to use the package. Please visit the Asset Store to acquire the package and add it to your account:
      Access to 'https://download.packages.unity.com/com.meta.xr.simulator/-/com.meta.xr.simulator-64.0.0.tgz' was denied
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()

I can find loads of erros similar, but none seem to have the  "grant" issue.  

Does anyone have any thoughts or things I could try..  

I can confirm that I am using the same logins for the asset store and unity

its a 2022.3.28f1 project.

I think they are all dependencies, but I cant access them.. 

any insight would be greatly appreciated. 

 

1 ACCEPTED SOLUTION

Accepted Solutions

ABigBigWhale
Oculus Staff

Hi folks. Thank you for reporting this issue. It should be fixed now.

As a note, we also host these packages on https://npm.developer.oculus.com/ as a backup, in case future needs arrive.

View solution in original post

10 REPLIES 10

bilgekagan
Protege

Can you try add package with name.

To add, Press + button in package manager then add package by name, and paste this: com.meta.xr.sdk.all 

Thanks for the idea..  but unfortunately caused the same error..  

ABigBigWhale
Oculus Staff

Thank you for reporting the issue! We are currently investigating.

bcerf
Honored Guest

I have the exact same problem on Unity 2022.3.29f1, can't figure out what's happening

I have a work around, so @bcerf if you are having the issue with the "all in one" specifically

https://assetstore.unity.com/packages/tools/integration/meta-xr-all-in-one-sdk-269657

i just went through each dependency and found them in the store and added them..  when i had done them all, it did install..  ( was a pain, but i want to start building! ) 

but is a workaround, so not ideal for people following the tutorial.  @ABigBigWhale still is worth looking at the issue for others..  

 

 

I can confirm that this is the working solution. I had the same trouble, when trying to update the SDK from v63 to v64 via the Unity Package Manager.

After adding every single asset on this page to my account, I was able to update the SDK version in the Package Manager.

EDIT: Just saw that Meta apparently pushed the SDK v65 Update today (see v65 in the asset store, but not available in the package manager), so probably something went wrong with the update and the permissions

I run through these tutorials every 6 months or so, and until this version it always worked like a dream!!  @JoJue I hit another issue with this set up, and sounds like you have just done the same journey..  

when i use the oculus > Tools > project set up tool  

it doesn't clear the two erros for installing Oculus XR Plug-in and XR Plug-in Management package  even tho the tutorial says it will automatically install both..  

I did sdearch the store for both, and nothing came up..  did you get a this issue too, and get a work around?  

 

or does anyone know the real names of them, since Oculus XR Plug-in and XR Plug-in Management package brings me nothing!  

 

 

Hey @aberbotimue, so I just tested it and I was able to download and integrate the package.

Heres what I did:

- Open new project (Editor v 2022.3.18)

- Switch Platform to Android

- Install Meta All in One SDK via Package Manager

- Go to the Project Setup Tool and press "Fix All" in the upper right corner, until all errors are resolved

Thanks for that @JoJue - Looks like I have a unique issue, as I did exactly what you described, and it left two issues behind..  Again, appreciate the reply.  I'll raise a second post as don't want to pollute this post for anyone needing the workaround for the original issue..