Showing results for 
Search instead for 
Did you mean: 

TextMeshPro 3 Deprecated, remove it from Meta XR v59 package


Hello, can you remove TextMeshPro 3 dependecies from Meta XR package?

TextMeshPro 4 is now built-in and it conflicted with TMP3 on Unity 2023.3alpha

See screenshoot: 


Accepted Solutions


Confirmed today, TextMeshPro 3 error has been fixed in Unity 2023 version with the TextMeshPro 4 shim version. Fixed in Unity 2023.2.7 and 2023.3.0b3+ 2024_January_25_2137_chrome_IFv6MANLj4.jpg

View solution in original post


Honored Guest

The TextMeshPro v3.0.6 dependency in com.meta.xr.sdk.interaction v59.0.0 package also breaks non-alpha Unity 2023.2.0.


Temporary workaround:

If you do need to work on Unity 2023.2 with TextMeshPro dependent packages, please manually change the dependencies of the UPM package to use UGUI 2.0 and remove TextMeshPro

Thanks. How can I do it?

In Unity Editor, in the Project panel, scroll down to Packages and find the package that uses TextMeshPro as a dependency (in this case Meta XR Interaction SDK and Meta XR Interaction SDK OVR Integration). In the root folder of that package should be a package.json file. You can open that in a text editor and delete the entry for com.unity.textmeshpro in the 'dependencies' list. Once you've removed TMPro as a dependency from all packages, you can delete the TMPro package from the Libraries folder. Good luck!


Hello, one month and 2023.2.3 and v60 Meta SDK now, still the same error with TMP3. Just want to bump this issue for Meta dev team.

Tried it as well this morning and I can confirm the dependency is still present in 60.0 running on 2023.2.3f1. The workaround suggested by @jreinjr doesn't seem to work for me either, as I've opened every single package,json file and removed any dependencies I could find to TextMeshPro, but for some reason, even after a full reboot, the TextMeshPro package still reports being imported as a dependency of the Meta XR All-in-one SDK package, so UPM won't allow me to remove it.


Edit: I've also tried editing the packages-lock.json and the ProjectCache to remove any dependency to TextMeshPro, but no matter what I do, Unity restore them on opening the project so I still can't remove the TextMeshPro package.

Go to these directories after importing v60 Meta SDK: 

Open the package json file and delete the line "com.unity.textmeshpro", then delete manually the folder com.unity.textmeshpro@3.0.6 I was able to make it run without prompting errors. But since this is a manual method, I'd like Meta to remove TMP3 or somehow make an option to optionally import TMP3 later for Unity < 2023.2 as I can see all the sample scenes are currently using TMP so obviously that's why it's happening, it's just that Unity abruptly changed how TMP4 as default package in the new version that led to this minor yet annoying error.

You'll also need to delete the actual TextMeshPro package folder from Windows Explorer (not from within Unity) after removing all dependencies from package.json


Another bump for the Meta dev team. It's still not working. All the solutions here are pretty useless because it's only temporary changes in the cache.

Can't be so difficult to simply remove that dependecy?! In worst case just make a separate package only for Unity 2023.2+ or so?