cancel
Showing results for 
Search instead for 
Did you mean: 

URP and Quest

CapraMambrica
Honored Guest

Can I use URP on Quest, and if so, can you help me find the docs?

 

While a veteran of the VFX industry, I'm a virgin with game dev and Unity. I have been trying to understand the different rendering pipelines in Unity, I like what I see in URP and I have seen several examples that suggest to me it works on Quest. However after many battles today I cannot get even the most basic scene to build without an "[your app] keeps stopping" prompt on the Quest. I can build normal scenes just fine to the Quest. 

 

I have tried both starting from a "3d" template, and a "3d (URP)", importing the "Oculus Integration" and "Universal RP" as and if required. Then confirming the build and player settings as per the docs. But nothing. 

 

I have also tried converting a working scene to URP, but once it's linked in the "Scriptable Render Pipeline Settings", it crashes.

 

The builds goes through without error, but won't run on the Quest. When I select "App Info" on that prompt, I just get returned to the main Home Screen. I don't even see the "Made with Unity" splash. 

 

I'm on Unity 2021.3.1f1, and my Quest is on the latest OS, 40.0.

Any guidance would be greatly appreciated. Thanks!

0 REPLIES 0