cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to use eye-tracking in Unity by Oculus integration

nmns
Honored Guest
Hello Oculus Developers, I hope this message finds you well.
I am currently facing an issue in Unity 2020.3.40fc1 while trying to use the eye-tracking technique by the up-to-date Oculus Integration.
I kept getting this warning issue and cannot use the OVR Eye gaze script using Quest pro. Could you plz help me?
(The permission of eye-tracking has been opened in the Oculus app and device. The warning is as follows:
> [OVREyeGaze] Failed to start eye tracking.
UnityEngine.Debug:LogWarning (object)
OVREyeGaze:StartEyeTracking () (at Assets/Oculus/VR/Scripts/OVREyeGaze.cs:136)
OVREyeGaze:OnEnable () (at Assets/Oculus/VR/Scripts/OVREyeGaze.cs:110)
UnityEngine.GUIUtility: ProcessEvent (int,intptr,bool&)
 
Since the old integration has been deprecated, I tried to add the new Meta XR SDK Core package in a new project of Unity 2022.3.7f1c1. But I am receiving the following error:
> [Package Manager Window] Error adding package: com.meta.xr.sdk.core@59.0.0.
undefined == true
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()
0 REPLIES 0