Showing results for 
Search instead for 
Did you mean: 

Virtual Reality SDK Oculus failed to initialize, why?

Ok so i downloaded Unity 2017.4.0f1
I also got the latest Oculus Utilities.

And when i press play this are the messages i get

Virtual Reality SDK Oculus failed to initialize.
Attempting to enable OpenVR instead.

XR: OpenVR Error! OpenVR failed initialization with error code VRInitError_Init_PathRegistryNotFound: "Installation path could not be located (110)"!

Virtual Reality SDK OpenVR failed to initialize.
Attempting to enable None instead.

Unity v2017.4.0f1, Oculus Utilities v1.24.0, OVRPlugin v1.24.0, SDK v0.0.0.
OVRManager:Awake() (at Assets/OVR/Scripts/OVRManager.cs:904)

I don't know why i get that. In My Player Settings  /XR Settings  I have Virtual Reality Supported checked and then listed are the Oculus  with an arrow pointing to it and then below that OpenVR.

And i intend to build for the RIft.
This process worked fine back in Unity 5 when i tried it. But what should i do to make it work in Unity 2017.4?


@CTNRSM Still not working for me, using Unity 2019.2.5f1

Also, there's no option to disable the spazialiser in the inspector when following your steps. Help please

It works for me thanks.


@CTNRSM Still not working for me, using Unity 2019.2.5f1

Also, there's no option to disable the spazialiser in the inspector when following your steps. Help please

When you select the spatializer plugin in the Unity editor, the inspector should show something like this:


I'm not sure what else you could do if it doesn't work. I wish I could offer more help, I can only tell you what solved the issue for me.

I seem to be having a related issue that I posted in the Unity forums (along with mis-spelling "Oculus"):

In short, having the spatializer enabled causes Unity to try to launch in the headset on boot, which doesn't make a lot of sense. The loading screen gets stuck and any further attempts to start the editor fail to render in the headset. If I disable the spatializer on boot, but then turn it on once I'm in Unity, everything works. This behavior also started somewhat out of the blue--this exact setup was working fine until it stopped working. At that point, even with a new Unity install, updated tools, and updated Oculus app, it stayed broken.

Not applicable
How is it possible that this bug is still not fixed? We've been running into this issue for ages and I had no idea why Oculus sometimes refuses to start up until I found this thread. Things like restarting Oculus or rebooting the computer seemed to work sometimes, but removing the Oculus Spatializer files is the only thing that seems to fix it reliably! Just disabling the spatializer in the settings doesn't seem to work either, you have to completly remove the .dll from your Assets folder.

If Oculus Integrations prints out SDK v0.0.0, double check you have the Oculus Desktop and Oculus Android installed in your Package Manager. That was an easy thing I missed.

Not applicable
Has this been fixed yet?  I'm getting "Virtual Reality SDK Oculus failed to initialize. Will attempt to enable OpenVR instead." after installing the Oculus integration kit, while it worked perfectly before.

Honored Guest
I'm also having the same issues, tried setting up a new project and did the exact same workflow that worked for me before.
So for me that is the weirdest thing. It worked and now it doesn't. I'm blaming the latest Oculus Integration release!

Unity 2019.2.2f1
Oculus Integration 13.0
Oculus Desktop 1.38.4
Oculus Android 1.38.6

This is unbelievably annoying. It hinders and destroys all momentum.

Hey, did anyone find a solution to this? I am getting a similar error when I try to upload to the alpha channel saying "Oculus SDK not found or older than 1.0," even though in the Unity editor it says 1.50 for the SDK version, after I ran Unity as an administrator (before it was saying version 0.0.0 for the SDK). I am using Unity version 2017.4.40f1, Oculus Utilities version 1.49, OVRPlugin version 1.49.