Showing results for 
Search instead for 
Did you mean: 

Voip is not asking for microphone permission

Level 4

I have realized this after upgrading Unity and Oculus Integration package, and tried it out on the samples to see if I have something wrong in my project. But same problem happens on the `VrVoiceChat` sample. 


To produce:

1- New project in Unity

2- Download and set up Oculus Integration (37.0)

3- I use legacy XR settings to enable VR

4- build, install and open

5- invite someone and see microphone permission popup is not showing up hence voice chat is not working (voice start working after giving the permission manually)


Unity version: 2019.4.33f1

tried on Quest 2

I think it was asking for the permission on the Oculus Integration 25.0 when a voip was starting up (if the permission weren't given before)

Any ideas, should I just use the default android permission asking methods? 


Level 4

Turns out LipSyncMicInput was using UnityEngine.Microphone methods and that's how the permission prompt was popping up. Though it is still weird to me that no microphone permission is asked for the voip while lipsync is asking for that. Also i am having problems with Meta Avatar lipsync and VOIP working together

Thank you for your answer. I have the same question. Everything is normal after calling the Microphone.GetDeviceCaps function. The official case is too deceptive