cancel
Showing results for 
Search instead for 
Did you mean: 

v62 ControllerDrivenHands broken?

TheDaddis
Protege

Hello,

I just updated to SDK v62, and after a little bit of confusion on where to get the samples (find them in the 'Samples' tab, for each package in the Package Manager window - it then adds them to Assets/, not Packages/), it seems that I can't get my controller-driven hands to show up.

At first I thought I was using the prefab wrong, but even if I open the official TouchGrabExamples scene, while hand-tracking works fine, if I pick up my controllers, the hand models do not appear. I have got "Controller Driven Hand Poses Type" set to "Natural" in the OVRCameraRig (the default setting in this sample).

It looks like the mesh renderer for the synthetic hands in the OVRControllerDrivenHands never gets enabled.

I'm using Unity 2022.3.14f1, testing over Quest Link. Am I missing something? If not, will it be fixed in v63?

10 REPLIES 10

Jayemby
Honored Guest

I'm literally just trying to make a simple app with controller-driven hands or synthetic hands or controllerhands or whatever meta calls it and I cannot seem to. I tried the building blocks, adding controllers, and setting the display to "hands" on both (after setting "conform to controllers" for controller-driven hand poses type) and that just shows two broken right controllers in both hands...

TheDaddis
Protege

I tried making a build on a punt and then the hands do actually show up, so the problem (for me at least) does seem to be limited to in-editor and using Quest Link (but that's still quite a problem).

In your case, can you start with the TouchGrabExamples scene and work backwards?

E.n.g.1.n.e.e.r
Explorer

Indeed, it seems to ne broken. Did not work for ne either with the old OVR integration example, nor manual setup, nor building Blocks. But of you make a build, it works. Unfortunately the simultanious hand and Controller tracking only works over link....not in the build. Very annoying and time consuming.

Big_Flex
Expert Protege

Hi @TheDaddis, is your Quest Link software up to date?  

TheDaddis
Protege

I think so. I'm on Runtime Version 62.0.0.235.346.

seahound.games
Honored Guest

Has anyone had any success with this? I'm unable to see or use controllers in the HandGrab or TrouchGrab example scenes, whether through Link or an actual build.

rineksoSimson
Explorer

me too man, still stuck, and I just downgrade the package. I hate to do that.

DNightOwl
Honored Guest

I managed to make the OVRControllerDrivenHands work but am not sure if its the right way to do it

DNightOwl_0-1712587734885.png

 

What did you end up having to do to get your current version to work? I've also been tweaking OVRControllerDrivenHands to try and get this feature working again.