Showing results for 
Search instead for 
Did you mean: 

Cannot connect Unreal Insights with App Lab game with Quest 2

Level 4

I am stuck trying to see Unreal Insights for my app which I am developing through the App Lab.


I've tried the following 2 guides, but they are so poorly written, I don't know if I am missing some key steps in between.


So Far, I've connected my Quest 2 through USB. And I have a Beta build installed through App Lab in my Quest 2. I can launch and play my app no issues. Unreal 4.27


Then I set up TCP connections, by opening a Command Prompt and doing this "adb reverse tcp:1980 tcp:1980" and I get a return value of 1980.




Next I set up the UE4CommandLine.txt which is under This PC\Quest 2\Internal shared storage\UE4Game\MusicalRange\UE4CommandLine.txt which is a path in the Oculus Quest 2.


I have tried various variations of these txt files. I know it is updated in the quest, because I can see the file size change which each version.


The 3 versions are ID Redaced to random characters

  • ../../../MusicalRange/MusicalRange.uproject -Messaging -SessionId=ABABABA565656 -SessionOwner="Eugenio" -SessionName="Quest_2 (CDCDCD898989)" -cpuprofilertrace -statnamedevents -tracehost=
  • ../../../MusicalRange/MusicalRange.uproject -Messaging -SessionId=ABABABA565656-SessionOwner="Eugenio" -SessionName="Quest_2 (CDCDCD898989)" -cpuprofilertrace -trace=log,counters,cpu,frame,bookmark,file,loadtime,gpu,rhicommands,rendercommands,object -statnamedevents -tracehost= -tracefile=-tracefile=/sdcard/UE4Game/MostRecentTraceCapture.utrace
  • ../../../MusicalRange/MusicalRange.uproject /Game/MusicalRangeReloaded/Maps/Map_MRR_ShootingRange -trace=log,counters,cpu,frame,bookmark,file,loadtime,gpu,rhicommands,rendercommands,object -statnamedevents -tracehost= -tracefile=-tracefile=/sdcard/UE4Game/MostRecentTraceCapture.utrace

Next, I open up Unreal Insights, enable Auto Start Analysis, but no session ever shows up when I run app on my Quest 2.









All guides seem to indicate that it's done. It should be working.


What am I missing?


Level 7

Apologies for the slow response. I got around to looking at this. It's definitely not as straight forward as it should be.


Here's what worked for me:

  • Create ue4commandline.txt (All lower case. Not sure if it matters, but this is what I used)
  • Contents of ue4commandline.txt are: 
    -tracehost= -cpuprofilertrace -statnamedevents​
  • adb push .\ue4commandline.txt /sdcard/UE4Game/<Project Name>
  • adb reverse tcp:1980 tcp:1980
  • Run Unreal Insights
  • Launch app on device

Thanks for the reply! Just one questions on your steps.


When you say 'Create ue4commandline.txt' , where do you create it? In what folder location?

You can create ue4commanline.txt anywhere you want as long as your command prompt is at the same directory when you run the adb push command. I created mine in the same folder as my packaged apk.