Showing results for 
Search instead for 
Did you mean: 

Crash on Assertion failed: Texture->GetFormat() VulkanRenderTarget.cpp::1439 on Quest 3


We have an app that works fine on Quest 2, using Unreal 5.1.1 + MetaXR plugin version 1.82

Our app works fine on Quest 2, in both development and shipping configurations, but when we install that exact APK on the Quest 3, we are getting this error from the development version

[2023.10.20-15.18.55:526][  0]LogHMD: Setting user focus to game viewport since session status is visible...
[2023.10.20-15.18.55:526][  0]LogAndroid: Display: Low Power Mode Changed: 0
[2023.10.20-15.18.55:532][  1]LogHMD: Allocating Oculus 53 x 55 variable resolution swapchain
[2023.10.20-15.18.55:542][  2]LogSerialization: Display: IgnoreInlineDataReloadEnsures: 'false'
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: === Critical error: ===
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: 
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: Assertion failed: Texture->GetFormat() == GRHIVariableRateShadingImageFormat [File:D:/build/++UE5/Sync/Engine/Source/Runtime/VulkanRHI/Private/VulkanRenderTarget.cpp] [Line: 1439] 
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: 
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1FE49788!FVulkanRenderTargetLayout::FVulkanRenderTargetLayout(FVulkanDevice&, FRHIRenderPassInfo const&, VkImageLayout)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1FE46F9C!FVulkanCommandListContext::RHIBeginRenderPass(FRHIRenderPassInfo const&, char16_t const*)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2195720C!FRHICommandBeginRenderPass::Execute(FRHICommandListBase&)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1D956AB0!FRHICommand<FRHICommandBeginRenderPass, FRHICommandBeginRenderPassString1260>::ExecuteAndDestruct(FRHICommandListBase&, FRHICommandListDebugContext&)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F21962BEC!FRHICommandListBase::Execute(TRHIPipelineArray<IRHIComputeContext*>&)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2196538C!FRHICommandListImmediate::ExecuteAndReset()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2196A0FC!FRHICommandList::EndScene()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2325968C![Unknown]()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F21A352D4!FRDGBuilder::ExecutePass(FRDGPass*, FRHIComputeCommandList&)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F21A31630!FRDGBuilder::Execute()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2325C090![Unknown]()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2325F164![Unknown]()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1FEFC58C!FNamedTaskThread::ProcessTasksNamedThread(int, bool)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1FEFA848!FNamedTaskThread::ProcessTasksUntilQuit(int)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1FEF9908!FTaskGraphCompatibilityImplementation::ProcessThreadUntilRequestReturn(ENamedThreads::Type)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F21ADA768!RenderingThreadMain(FEvent*)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F21B07308!FRenderingThread::Run()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F2009CC0C!FRunnableThreadPThread::Run()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000006F1FEF62E4!FRunnableThreadPThread::_ThreadProc(void*)  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x0000007034115DB4![Unknown]()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: [Callstack] 0x00000070340C23E0![Unknown]()  []
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: 
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: 
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: 
[2023.10.20-15.18.55:942][  2]LogAndroid: Error: 
[2023.10.20-15.18.55:952][  2]LogExit: Executing StaticShutdownAfterError
[2023.10.20-15.18.55:952][  2]LogAndroid: FAndroidMisc::RequestExit(1)


I have been able to reproduce the exact same error, by creating a new project based on the unreal´s VR template, adding MetaXR plugin, and compiling for Android Development, so it may be a problem from the plugin or the engine


I have tried the same, using and empty project, and configuring everything as the Meta Quest 2 quick start, and the project also crashes

I think that there should be a project setting, but I dont know wich to try 😞

Heroic Explorer

Are you using unreal 5.1.1? or 5.2.1? I dont think unreal 5.1 is supported for meta quest 3, only unreal 5.2.1 and unreal 4.27

Yes, we are using 5.1.1 + Oculus Quest 2 without problems, also it works fine for the oculus quest 3 using shipping configuration, but when I package a development version, it crashes on startup

Where did you find that 5.1.1 is not suported? On MetaXR plugin v53 download, the 5.1.1 is listed as requirement 

I meant for meta quest 3. Because in the MetaXR plugin v56 it says "support for meta quest 3 device" (in the "Whats New" topic, which means that wasn't supported)
and the Unreal supported is 5.2.1

Unreal 5.1.1 is supported for meta quest 2. You build an apk that works on quest 3 could be a lucky thing, maybe.



have you guys found a solution to this?

I'm getting the same problem going from Quest Pro to Quest 3.

I'm on UE 5.2.1, so should be supported according to dario.maciel.