Showing results for 
Search instead for 
Did you mean: 

Crash on every RTX project

Level 2

I've built a VR archviz experience using ray tracing for reflections. It was a bit of work to learn how much RTX stuff I could fit in the project while keeping a good FPS rate. I amb very happy with the result and I have had stable versions during the last two months. During development it never crashed (except once that I solved by installing new gpu drivers) or gave any problem further than low FPS, when RTX settings (or other expensive stuff) were too demanding.

The problem is that last Friday, I was introducing last minute minor changes before showing it to the client on Monday, and realized that it was not working anymore. Not only the new version, but previous versions that date a month and had been working until now. There's no way I can execute the project, both the editor and build crash. And it is not only on my computer, it crashes on every computer I've tried, all of them with 2080, 2080 Super, and 2080 Ti. The only computer were it still works it's a laptop with a 2080 that probably hasn't installed the latest Oculus update.

Furthermore, I've tried to make a new project based on the VR template. Default settings work fine, but as soon as I check DirectX12 and ray trace it just won't run. Everytime it gets stuck in some kind of Oculus loading screen and after a minute or so I get these errors:
(this one is from the default VR template)
(this one is from the las working build of the archviz project, which is much heavier)

Right now I'm blaming the last Oculus update because it's the only thing that has changed since it last worked. So far I've tried updating graphics card drivers to the latest version but this time it solved nothing. I also have tried on three different machines and builds that have worked before. Tomorrow I may try to do it on Unity.

Unfortunately it does not seem possible to go back to the previous Oculus version and also, I can't test with other glasses right now. Is anyone else having the same problem? Is there something else I can do to help identify the problem or solve somehow, even if it is something temporary?

It's been a huge setback to experience this just when we were going to show our client. We're working on a DirectX11 version using reflection probes so we can land it somehow. But yeah, not ideal.

I'm using Oculus app version ( I've tried both Unreal 4.25.1 and 4.25.2. Probably one of the older builds was built with 4.24.3. I seem not to be able to share a project since it is too big and I can't share links here, I think it'll be easy to reproduce with the instructions I gave above.

I hope somebody can help!

Have a nice day!

Level 2
Little update here!

So I had the chance to try with a non oculus set, and works as expected. It must be then an Oculus thing.