cancel
Showing results for 
Search instead for 
Did you mean: 

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

3d-illusions.co.uk
Adventurer

I keep getting a gradle 8 error, and I'm unsure how to fix it.

setup below.  unreal 5.3.2.  Could anyone tell me what I've done wrong and how to fix please?

 

3dillusionscouk_3-1717085354221.png3dillusionscouk_4-1717085379406.png3dillusionscouk_5-1717085392464.png3dillusionscouk_6-1717085405394.png3dillusionscouk_7-1717085417092.png3dillusionscouk_8-1717085434695.png3dillusionscouk_9-1717085446189.png

 

 

 

 

 

4 REPLIES 4

Sooraj26
Honored Guest

Hey I am facing this problem as well please post an update or solution if it has worked for you.

The Meta setup instructions link to an unreal page that lists the incorrect information.  For Unreal 4.3.2 this works: 

3dillusionscouk_0-1718627456619.png3dillusionscouk_1-1718627472648.png3dillusionscouk_2-1718627486472.png3dillusionscouk_3-1718627498295.png

3dillusionscouk_4-1718627511319.png

3dillusionscouk_0-1718639327274.png

 

 

 

3d-illusions.co.uk
Adventurer

Why Meta can't take the time to maintain their own page with correct android version information for each Unreal version I have no idea.  It would save everyone a ton of time.

dredgeho2
Explorer

I found these settings to work for me in UE 5.2 Windows 11. 

android SDK for UE5.2.png

You might need to check the environment settings in windows. Click 'start' (windows logo) then the gear icon for settings then type in the 'find a setting' search: "env" And it will show "edit the system environment variables. From there you have to click 'environment variables' at the bottom. Then you need to check that all the paths are correct. 

I wasn't able to use Java 17 unless compiling in 5.3 or 5.4.  You likely need to use  jre1.8... 

Also:  Another Gradle error was solved by deleting intermediate, binary and saved folder from project.