Showing results for 
Search instead for 
Did you mean: 

Get Oculus Identity returns No Logged In user

Honored Guest
I try to get my ID with GetOculusIdentity node but it fails and prints out
LogOnlineIdentity: Warning: Oculus: Failed Oculus login. Not currently logged into Oculus.  Make sure Oculus is running and you are entitled to the app.
Also  tried Get Oculus ID and it also returns
 No logged in user
I run Verify Entitlement before and it succeeds, I have the correct appid of my game in my DefaultEngine.ini and the account passes authentication


I have encountered the same issue.

Expert Protege

I'm encountering the same (or similar) issue! The entitlement check passes, but when I get the user name it's blank. It used to work just fine, and then for whatever reason it no longer does.


I just made a thread about it here:

I'm a casual dev at this point, but I'd first encountered this issue when I was doing the Oculus Tutorial through Unreal Engine a few weeks ago. At least two others experience my same issue, which presents when trying to access Guardian functions after checking to see if Guardian is Configured, which fails, despite passing the initial Verify Entitlement.


So, again, I am quite new to this but I think the "No Logged In user" warning is the larger issue, and I guess we wait for a fix from Oculus, as I assume this is a problem that only started appearing recently. The people in the thread I link to first noticed this in ~January, whereas that tutorial had worked at least as of 5/2020.


I suspect something about the Facebook account merge is the root cause, as I've tested as many other factors as I can consider, and even the Unreal's course instructor had not known what could be at issue.


Expert Protege

We just started getting this issue also.


hey, have you filled the data usage docs? only a few minutes, you can find the link on Dashboard, until it is not done, login would fail, only entitlement check would pass. I sucked a lot because of it 😄

Do you mean the Developer Distribution Agreement and Developer Non-Disclosure Agreement?  Yes, I did indeed sign those, though funny you should mention it as it *was* something I'd missed when I initially encountered the issue, and had high hopes that was the solution.


The other area I've wondered about is the fact that the Oculuslinked Quest 2 is not *actually* Rift, though the app is designated as such (which is allegedly fine, according to the tutorial). And  I've been progressing with building it regardless, but it occurs to me maybe the Quest relationship to Android is somehow a factor. Beyond declaring the RiftAppId/OculusAppId into a Config/Android/AndroidEngine.ini, and updating Oculus ADB Drivers, and putting Android SDK and NDK into the project settings (none of which I think should be necessary), not sure what other steps to take...


No, at Application Dashboard, at API, you should see a userID code. if there is a text mentioning to fill a doc, do that, because it is blocking it.

Wow- thank you!  That was exactly it.


From the Dev Dash, I went to "edit details" for the app, then saw under API I still needed to do the Data Use Checkup, and selected UserID and User Profile, and permission was granted immediately (I think these must only need a request to be submitted and are auto-approved)


It yet didn't fix my Guardian Issue, but at least I can rule that out as a factor.  Big help.

Expert Protege

Thanks, that was the problem for us!