cancel
Showing results for 
Search instead for 
Did you mean: 

HandTracking NotWork

dipRio
Honored Guest

I'm trying to use Hand Tracking with Unreal Engine 5.3.2. I'm using Quest 2 as the main device.

I worked while watching the following tutorial: "VR Hand Tracking in Unreal Engine 5.3 | Tutorial for Beginners<iframe width="560" height="315" src="https://www.youtube.com/embed/empovwgouwI?si=Fwo97_u04KzT3BiC" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture; web-share" referrerpolicy="strict-origin-when-cross-origin" allowfullscreen></iframe>

One difference is that when importing the MetaXR plugin, I downloaded it directly from the Marketplace instead of using the external link as shown in the video (probably version 64?). I tried manually installing version 60, which was used in the video, into the plugins, but I abandoned it because I encountered an error "Unhandled Exception: EXCEPTION_ACCESS_VIOLATION Meta XR" leading to a crash.
 
Currently, I'm using the version 64 (?) plugin downloaded from the Marketplace and performing the following:
 
Assembling VRPawn
Setting up VRGameMode
Change MetaXR in project settings
Setting up Runtime OpenXR for the Link app
Turning on the Developer Runtime feature of the Link app's beta
Connecting the Link using a Type-C cable
However, the hands are not appearing at all. Also, I'm seeing numerous errors like:
 
 
 
LogOVRPlugin: Error: [XRCMD][failure] [XR_ERROR_HANDLE_INVALID]: xrGetHandMeshFB(handTracker, &xrMesh), arvr\projects\integrations\OVRPlugin\Src\Util\CompositorOpenXR.cpp:8115 (arvr\projects\integrations\OVRPlugin\Src\Util\CompositorOpenXR.h:312)
 
I've also tried:
 
Switching the Quest 2 to Developer Mode from the mobile application on Android
Installing Developer Hub
Installing Android Studio
Running SetupAndroid
But it seems unnecessary according to the tutorial. What else is needed to make Hand Tracking work?
 
3 REPLIES 3

MetaQuestSupport
Community Manager
Community Manager

Hi there @dipRio! Thank you for reaching out in regards to this matter. We would love to take as further look to see what may be causing this problem. Since this is specific to Unreal Engine 5.3.2. development, we may not have available troubleshooting to assist with this.

That being said, we hope our awesome community is able to chime in with some helpful insight! Please feel free to update this thread if there are any changes. Hope to hear from you soon! Have an awesome day!

MetaQuestSupport
Community Manager
Community Manager

Thank you so much for contacting us directly. We will work with you directly through private messages now! Please keep an eye out for our reply.

Iamaho
Honored Guest

Hi. Wonder if you've got any solution? Came across the same problem now. I was working on a project on UE5.3 and Quest 2 last month and hand tracking was working perfectly. I bought a new Quest 3 last week, and just found out that hand tracking was not working at all and threw an access violation error in OculusXRHandComponent.cpp, line 93: UOculusXRInputFunctionLibrary::IsHandTrackingEnabled().