cancel
Showing results for 
Search instead for 
Did you mean: 

Meta XR Platform

Sir_davis3
Explorer

Hey Everyone,

Looking for some help in using the Meta XR Platform Plugin for Epic installer 5.3.2.
I went through the installation process several times at this point, and enabling and calling functions from the Meta XR Platform plugin, causes errors.  While the app packages and launches without issues, none of the nodes from the plugin work.
I'd like to be able to get username and to set Display Frame Frequency.

Does everyone have experience installing and using this plugin?
Here is the link:
https://developer.oculus.com/downloads/package/unreal-5-platform-sdk-plugin/

I appreciate any help or advice.

15 REPLIES 15

That's weird, i would ask what is your platform version to check against mine, which is also 1.94

Helder_Vinicius_0-1709906211570.png

 

Maybe it's the source engine issue @TetraStudios mentioned, I have a custom engine and i have both Meta XR and Meta XR Plaform Plugins built for a custom 5.3.2. If you want i can try to upload them so you can test. Let me know

TetraStudios
Explorer

@Helder_Vinicius What did you do to get that plugin working? It kept giving me linker issues when I built to headset.

@TetraStudios Not sure, I'm using a source engine build. Not really sure if the MetaXR Plugin is under Plugins/Marketplace or Plugins/Runtime folder, but i've packaged for Quest, Windows,  and a windows dedicated server without issues so far.  My MetaXRPlatform Plugin is under Project/Plugins for sure tho.

How are you building your apk?

Sir_davis3
Explorer

I'm using Epic installation of 5.3.2, not source. My Platform XR Plugin is in the Engine marketplace folder, I could try to move it. 
I also susbect that something in the Engine/source/thirdparty/oculus folder might not be right. Maybe if someone could share that folder that might help. None of the functions from Meta XR Platform work (except maybe verification). App would be ready to be submitted, but I need to get username.

I feel your pain, guys.  Is the problem here that no one at Meta has built and deployed an Unreal Engine 5 project before?  I feel like we're being left out here in the cold.  C'mon Meta, can you guys comment on this stuff?

Everyone in here, myself included, are wondering what the deal is with the MetaXRPlatform plugin. 

My big question is, if you download and compile the github fork of Unreal Engine, why is the MetaXRPlatform plugin not built in and not functional in that build (But the MetaXR plugin is)  What is the correct way to do an entitlement check on the current version of the Unreal Engine github fork?  (UnrealEngine-oculus-5.3.2-release-1.97.0-v65.0)????

Alright well, that's about 72 hours of building, retrying things, and pulling my hair out.  Here's what I've managed to sort out;

Using the Unreal Engine 5.3.2 from the Epic Games launcher:

Download the MetaXR plugin from here:  https://developer.oculus.com/downloads/package/unreal-engine-5-integration/
Download the MetaXRPlatform plugin from here:  https://developer.oculus.com/downloads/package/unreal-5-platform-sdk-plugin
Both of these should sit in your Unreal Plugins folder under a folder called "Marketplace".  These should work with the latest version of Unreal, but you don't get all of the sweet bells and whistles from the Unreal Meta Fork

I haven't tested the Entitlement check on the MetaXRPlugin so I can't speak to that.

Using the Unreal Engine 5.3.2 Meta Fork:

Downloaded from here https://github.com/Oculus-VR/UnrealEngine

and installed and compiled painstakingly over (for my computer) 4-6 hours. 

Once I compiled the version I got from the link above, it was missing the MetaXRPlatform.  I tried to install the MetaXRPlatform plugin like I did by putting it in the plugins/Marketplace folder but that didn't work for me.  

What did work for me was getting the MetaXRPlatform version from here:  https://github.com/oculus-samples/Unreal-SharedSpaces
After trying to put that version in the marketplace folder it also didn't work.  So I left the files in the marketplace folder, and then opened visual studio.  I added the Folder structure via "add filters" in the context menu and dragged the files from the folder into the right places.  Then I built the solution again.  Thankfully, VS is smart enough to only try to build things that need to be built. 

I tried this same process with MetaXRPlatform version 65.0, 64.0, 63.0, and 62.0 to no avail.  It was only the one that I downloaded from the link to 'shared-spaces' that worked for me.  It built successfully and when I started up my Unreal, the MetaXRPlatform was finally functioning in the version of Unreal that Meta modified and that I had to build on my machine.  I'm currently testing the Entitlement check.  I'm not 100% sure I have it working, but it looks like it's doing a check.