cancel
Showing results for 
Search instead for 
Did you mean: 

Meta XR Platform

Sir_davis3
Explorer

Hey Everyone,

Looking for some help in using the Meta XR Platform Plugin for Epic installer 5.3.2.
I went through the installation process several times at this point, and enabling and calling functions from the Meta XR Platform plugin, causes errors.  While the app packages and launches without issues, none of the nodes from the plugin work.
I'd like to be able to get username and to set Display Frame Frequency.

Does everyone have experience installing and using this plugin?
Here is the link:
https://developer.oculus.com/downloads/package/unreal-5-platform-sdk-plugin/

I appreciate any help or advice.

15 REPLIES 15

TetraStudios
Explorer

I've had the same problems with the source build of UE 5.3.2. It seems to be conflicting with files that are in the engine layer in:

UnrealEngine\Engine\Source\ThirdParty\Oculus\LibOVRPlatform

Unfortunately I don't have a solution currently. And I don't think you'll have access to these files in the binary/Epic Installer version of 5.3.2 anyway. But I hope someone else can help here! 

 

dario.maciel
Heroic Explorer

Do you need to use this SDK?
If you want to use the MetaXR plugin, try this link
https://developer.oculus.com/downloads/package/unreal-engine-5-integration

I really dont know the difference but this one I use and works flawlessly

The Oculus Source Build of Unreal Engine is a custom version of the engine that Oculus has made to enable certain features and enhance performance. I would only recommend it if you have a good grasp of the engine as it is quite hard to setup - https://developer.oculus.com/documentation/unreal/unreal-building-ue4-from-source/ 

It provides more features than the MetaXR plugin.

Hi dario.maciel,

Thanks for your reply!
I am using the Meta XR plugin as well and being able to access the settings is nice.
The problem is that in order to access the verify entitlement node, which is a submission requirement, you need to use the Meta XR Platform plugin. There are also a number of other nodes also tied to this plugin (Get username, set Frame rate etc).
This is one of the reasons why I'm surprised I can't find much information on it's installation or any possible errors. 
I tried a clean installation and new project with the VR template and I had the same result, where none of the nodes connected to Meta XR Platform fire and there are some errors upon startup and during build. (the app packages and launches though)

Hi TetraStudios,
It is good advice and I did consider that option, however for the purposes of my app the advanced features it allows would be neat, but not essential. 
I am also not fully confident in setting it up as I did attempt previously. I could probably do it but i believe it would take a lot of time.
The point of frustration is that I am very close to submitting, just need to set up Entitlement with the new Meta XR Platform plugin (which I cannot seem to do) and use a few other nodes it gives.
In 5.1 I was using the oculus subsystem plugin but that one is getting depreciated and Meta XR Platform is supposed to be taking it's place. Most of the guides on the Quest developer page already recommend a set up based on this, which is why it's a mistery why I'm failing to set it up after weeks of trying.
There are a number of posts out there on forums about it, but no cause or solution so far.

did you see this link?
https://developer.oculus.com/documentation/unreal/ps-setup/

or this?
https://developer.oculus.com/documentation/unreal/ps-entitlement-check/

i never used the plataform SDK plugin, so I cant help you with it.

Helder_Vinicius
Protege

Can you be more specific abouth the errors you are getting?

Is your app on AppLab (best in ALPHA release channel) and are you doing the entitlement check? After that, are you starting the message pump subsystem (i don't recall the exact name)

How do you handle verifying entitlement without the plugin?

Hi Helder_Vinicius, 

Yes the app is in the Alpha release channel.  In 5.1.1 I was using the Oculus Subsystem Plugin to verify entitlement and to access username. I set up the entitlement check and message pump system for 5.3.2 following the guide, but it has issues.

There are errors when launching the engine and errors during build.
Some errors on startup:

LogOculusXRAnchors: Warning: Unable to retrieve OculusXRHMD
LogHMD: Failed loading OVRPlugin 1.94.0


Errors when using nodes from the XR Platform plugin:
Get Display Frequency will produce this:

Warning: Attempted to access index 2 from array CallFunc_GetAvailableDisplayFrequencies_ReturnValue of length 0!

If I try changing Display Frequency without get, I get this error message:
LogOvrPlatform: Warning: Unhandled request id: 4 type: #00436f345d

The app launches and has no issues other than worse performance in 5.3.2 than with 5.1.1, but no Platform plugin related node works. I've been trying to find a solution for weeks now and other than this my app is ready for submission. I might try to revert back to using the depreciated Oculus subsystem Plugin to get entitlement verification.