Showing results for 
Search instead for 
Did you mean: 

New UE version 4.27 - changes / issues

Level 7

New UE version 4.27.0 - As before, I think its useful to put the changes / issues in one topic for an easy overview and to reduce wasting time trying to solve (known) issues.


210821 Just started testing so a short list:

- The official GPU lightmass is updated. The IES lights only work well with stationary lights at the moment. With static the light pattern is pointing in the wrong direction and this can't be changed in any way.

- The OpenXR plugin works out of the box with Quest. Just make sure the Oculus openXR plugin is enabled or it won't work. I did notice a massive performance drop when migrating a project to the default VR template that comes with 4.27.0. No clue why (yet). -> see edit 210823 and 210909

- Migrating 4.27.p4 projects to the 4.27.0 result in black meshes in Quest for me. No clue why (yet).

- In Movie Render Queue you now should be able to add batch rendering of camera's (still images) without going through sequencer as well. Just no documentation available yet how to do that and no new options in the UI.


Edit 210822:

- Could find any reason for the performance drop or the black meshes. So today created a brand new blank project, enabled openXR and Vulkan, migrated the same assets and made a new build. Its running fine at 72 fps in Quest. Must be some specific settings in the VRtemplate project OR in the migration project that broke it for me.


Edit 210823:

- Did some more tests. There's something in the VRtemplate 4.27.0 project that kills performance for the Quest 1 (20-ish fps). No clue and can't debug because when starting the app on the Quest with Renderdoc its stuck at the three blinking dots. So for now the best way to go is; create a totally blank new project (not using the vrTemplate) and go from there.

- dont install the Renderdoc plugin in UE or GPUlightmass won't work anymore (raytracing will be disabled)


Edit 210909:

- If you really need the vrTemplate functionality, the best way to go is create a brand new default project, migrate the vrTemplate map + key bindings into that and you will get a nice 72 fps on Quest1. The fps will drop a lot when shooting the cubes/ball though - something with physics maybe? Epic is already investigating the physics so maybe we'll see some solutions in 4.27.1


That's all for now. Hoping people can add to this list so we don't all waste time investigating / trying to fix the same issues.





Level 5

Have you tested on the Oculus Integrated source build of 27, or (as the date of this post implies) only tested on the Epic Launcher release? I'm seeing some OpenXR issues on the Oculus build, which is what prompts my question.

Level 7

I Only tested Epic's launcher version. The transition to OpenXR hasn't been completed yet (at least in Unreal) so I expect in the coming weeks/months, all these issues will be solved as long as people report them using the official channels.

Level 5

Have you tried uploading to Oculus? If so, how did you get entitlement to work with OpenXR?

With OculusVR plugin disabled I no longer have the verify entitlement node 😕

** NM, I wasn't enabling the Oculus Online Subsystem 😓 .. that took way longer than it should have to fix