Showing results for 
Search instead for 
Did you mean: 

No XR API Option Or Application Space Warp Option In UE4

Level 3

I would like to start development for Quest 2 Mobile in UE4. I want to utilize ASW but I'm having some trouble enabling it in the UE4 2.4X setting.

As you can see in the 2 pics below, I don't have options to enable XR API or ASW. I'm trying to follow this guide to get everything set up


Please let me know what I'm doing wrong and how to fix it so I can get started. Thanks.



Accepted Solutions

Correct repo, but that's an outdated branch. Go here for the current 4.27 branch:

View solution in original post


Level 7

Click the "Launch Oculus Platform Window" button and update if it prompts you to.


I'd also suggest turning off Instanced Stereo.

I turned off Instanced Stereo but "Launch Oculus Platform Window"  did not prompt me to update and didnt' really do anything. I'm still having the same problem.


No, I'm using base UE4 4.2. The repo u linked does not exist tho, did u mean to post a different page?

You must build UE4.27 from the Oculus fork to use ASW. You can't see the linked repo because you don't have access to Epic's github that it is forked from. 


Follow the instructions here to get setup with the necessary engine source. 

k so i installed the oculus fork. as u can see xr api is still not there and there's no mention of application spacewarp (i also tried to search for both, nothing..)



and i have set the launch performance setting as such. Are they set correctly for optimal quest performance?


As indicated in the Performance Check window, you need to disable MobileHDR and restart your editor. MobileHDR is not supported for Quest.

I disabled mobileHDR and restarted the engine. But XR API and application spacewarp are still nowhere to be found, unfortunately. Any other ideas?


So is this a lost case, or is there a fix, or do you need more info? Please let me know. Thanks.