Showing results for 
Search instead for 
Did you mean: 

Oculus Go controller input mapping on Unreal Engine 4.24.3?

This is most likely very very noob question, but I have googled for weeks for this...

Could anybody help me to figure out how to get the touchpad, trigger and back button on Go controller mapped to Unreal Engine 4.24.3 inputs?
There's no "Motion Controller Trigger, Thumbstick Up, ect." available and I can't figure out how to get touchpad to work either clicking or swiping up, down, left, right.

I would be very very grateful if somebody could please help me.

Heroic Explorer
They were broken in 4.24 but should be working again in 4.24.3 - haven't tested them myself though.

Did you look in the ProjectSettings-Inputs? Just add an Axis mapping and look for Oculus GO...
After that, you can use those events in the blueprints for moving etc.

Thank you for tip. I've tried all combinations I can guess, but I can only get the trigger and whole touch pad to work. I can't get the touch pads up and down sides separated no matter what I do.

Could you please, or anybody else, upload a template with just simply right Oculus Go input mappings setup on project? I can't find any sample for Unreal 4.24.3 that works and I'm currently stuck... 

Heroic Explorer
@silweri My GO is stored in a box - not using it much (using Quest) and lacking the time at the moment. Why not post on
Could be a bug OR maybe a GO user can help you there.

Thank you. I'll try there. At the mean time, everything seems to work with UE 4.23.1, so I'll continue with that.

Honored Guest
Still not working in 4.24.3.
Some Tests.

If I press trigger button shows: MotionController (R) FaceButton 1
If I press thumb touchpad shows (anyplace in touchpad): Oculus Go (R) Trackpad Touch
But it´s not receiving any action when I try to slide or swipe in thumb touchpad .

Honored Guest
I have the same problem with 4.24.3, which is supposedly the version that fixes the controller inputs through the bindings in the project settings (now the official or only way to access the Go controller).

Please note that the issue is marked as "FIXED" as of 4.24.3 on the Unreal Engine Issues for version 4.24. I'm too new here to be allowed to post links, but it is ticket  UE-85917 there. The issue is vaguely signified as one specific problem with one input from the controller and it is titled "VR Trackpad Axis Values 0".

I went back to 4.23.1 in which the controller is not an issue. 

There is also a recent thread on the Go controller issue with 4.24 in the UE4 Answerhub under the title "Where are Oculus Inputs in 4.24?" (again, I can't include links yet).

Either this issue lingers at Epic, or it isn't clear to them that it is one. Can we kindly ask Oculus to address the thing with them? It would be nice to keep up with the evolution of UE4, especially for new projects.