Showing results for 
Search instead for 
Did you mean: 

Oculus VR Plugin Missing in Unreal Editor Project Settings Menu - Intended Quest Development

I am trying to make an app for Oculus Quest using Unreal Engine and the Oculus VR plugin while developing on macOS. I wish to access the settings of the Oculus VR plugin in the Unreal Editor in the "Project Settings" panel in the "Plugins" section, but the OculusVR item does not appear (see first screenshot below) even though the Oculus VR plugin was enabled in the "Edit->Plugins" menu (see second screenshot below).


The expected appearance of the OculusVR plugin settings are described in the "Configure the Oculus Plugin for Unreal Engine" guide. I have followed all preliminary steps listed in Oculus' Quick-start guide for Unreal Engine development on Quest.

I have experienced this behavior with both the Unreal Engine editor binary download from the Epic Games Launcher, as well as from the editor I built from source using the Oculus-VR Unreal Engine repository.

The versions I used are:
    Epic Games Unreal Editor Binary: 4.25
    Oculus Source Code for Unreal Editor: 18.0 based on UE 4.25

I am developing on MacOS Mojave (10.14.6).

This same issue has been pointed out in other posts and forums. The solution mentioned in a couple of the posts is to download the Oculus Rift software, but this software only supports PC and not MacOS, so I am unable to use this. Surprisingly, this solution worked for PC users who were not attempting to develop for the Rift, but instead for the Quest. Another partial solution mentioned, which only allows you to modify the FFR setting for the plugin, is explained at the bottom of an Oculus guide on FFR in Unreal Engine.

Is there any known full solution to this issue, specifically when developing on MacOS? I assume it would be simple enough to see the plugin settings for a plugin which has been enabled in the Unreal Engine editor.

Thank you for any help on this topic.

I originally had many helfpful links inserted into this post, but the Oculus forum has prevented me from posting links because I am "too new". This greatly reduces the quality of this post and is very sad.

I have created a duplicate post on the Unreal Engine forum, so if you are looking for the links, please visit there!

Not applicable
Very strange no issues seeing it with Windows OS.

The fact you don't see it in either the epic launcher and the oculus source versions make it seem like a Mac issue. Did you experience the same in 4.24 as well?

Honored Guest
Ha, I got the same problem. My solution is to enable that "Oculus Avatar Plugin" . Then, I could see the menu appeared.

Interesting, I attempted the "Oculus Avatar Plugin" fix, but the settings still did not appear for me.

@aussieburgerVR I have not tried using 4.24, but I may download that earlier version to see if it will work. I wonder if the problem is somehow related to the version of MacOS I am on. I am using Mojave, so I am one major OS update behind the most recent MacOS.

From what I can tell, these settings are only accessible when the Oculus VR Desktop App is running on Windows. Since there is not a version of the Oculus VR Desktop App for MacOS, these settings are inaccessible on Mac. I thought this might possibly be included in the Oculus Developer Hub software, but this did not work for me.

That's correct.  In addition, because you can't run the Oculus Desktop app, you can't pass an entitlement check since Unreal uses the Oculus user signed in via the Oculus software to check the entitlement.

This doesn't mean you can't develop a Quest game on MacOS.  As long as you don't need any of the Oculus specific things, VR works just fine to develop and build/deploy to the Quest.  But if you want Avatar, Audio Spatialization, or any other Platform specific things, you'll have to use Bootcamp.

@Jattier thanks for your input! I have been using Parallels Desktop for Mac to get around this. In addition, some of the Oculus VR plugin settings which are needed for many apps such as Splash Screen, and Oculus-Android OS virtual keyboard are only accessible on Windows. I hope that the Oculus software required to use these tools gets ported into the new ODH (Oculus Developer Hub) for cross platform development including MacOS. I feel that ODH is the perfect candidate to receive these kinds of features, allowing for full development on MacOS in addition to Windows.

I have made a post requesting this feature for ODH and would appreciate anyone in support of this feature request to make a comment:

It would also be helpful to know if something like this will never be possible on MacOS.

I don't know.  With Apple deciding to move away from Intel chips, I might be on my last MacBook Pro.  I prefer to work in the BSD world, but with the Apple/Epic battle, chip changes and no longer being able to run Windows, etc., I'm afraid another brand is in my future.  So I don't have a lot of hope for a Mac/Oculus configuration.

Honored Guest
Same here on Windows10 & Unreal 4.24.3. 
OVR Plugin do not appear in the Project Settings.
Enabling Oculus Avatars Plugin help but i'm not sure this is a real solution...

Honored Guest

On a Win10 system but same Issue with UE4 4.26.1 with OculusVR plugin not showing up

Enabling Oculus Online Subsystem plugin fixed it.

Seems they are all tied together now.