Showing results for 
Search instead for 
Did you mean: 

Oculus client detects my Oculus 2 just fine, but Oculus development does not

Level 2

I'm trying to get started with developing on Unreal Engine, but I understand I cannot use the Oculus Client with Airlink as a way to do this already?  I have to use the Oculus Development app instead.  Problem is that it is trying to connect via Bluetooth and I am registered and everything but cannot detect my device.  Another issue I am having is trying to use Android studio I have it installed and when I try to use the Setup Android Batch file I get this message:


Android Studio Path: C:\Program Files\Android\Android Studio
Android Studio SDK Path: C:\Users\GAMING-PC\AppData\Local\Android\Sdk
Using sdkmanager: C:\Users\GAMING-PC\AppData\Local\Android\Sdk\tools\bin\sdkmanager.bat
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
at java.base/java.lang.ClassLoader.loadClass(
... 5 more
Update failed. Please check the Android Studio install.
Press any key to continue . . .


I'm kind of at a loss here I tried multiple websites with solutions one talking about a flutter doctor which I have no idea what that is cause command prompt cant find it.  Is anyone able to help me get started please and thankyou!


Level 2

So no one knows?

Level 5

Have you tried a USB-C cable?  Oculus sells them:

Oculus Link Cable: Unlock PC Powered VR With Your Quest 2 | Oculus