cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus samples not working

Cafeciao
Level 2

Hi everyone,

I am newbie in Oculus programming and Unreal engine programming.

I've just tried some samples of Oculus. I've downloaded it from https://github.com/Oculus-VR/UnrealEngine. Branch 4.27.

 

I can create sample project myself base on https://developer.oculus.com/documentation/unreal/unreal-gsg-quest-quickstart/. The project work fine on my Quest 2.

 

However, none of Oculus samples work on my Quest 2. (I've tried HandsTrainSample, HandSample and BoundarySample). They are just show nothing except dark.

 

Do you guys have any idea?

 

Thanks,

 

7 REPLIES 7

kavanavak
Level 4

Clarification Question: You can run the samples fine through Play-VRPreview? They just don't play when built (packaged) to the headset?
This might not be relevant, but I had to build each of the samples (visual studio) before they would launch.

The samples don't play on the headset (only sound plays). I've not tried on VR Preview yet(This menu is gray out).

 

Moreover, I've already built the samples on Visual Studio.

 

The samples don't play on the headset (only sound plays) but play fine in VR Preview.

Moreover, I've already built the samples on Visual Studio.

 

Do you have any idea ?

kavanavak
Level 4

I'm going to spitball a few things that might not help, but might:

- Are there any errors when you use VRPreview? If so, address them.

- How are you building to headset? Don't use the Launch option. Use File>PackageProject>Android and then install the APK that's generated. The Launcher does a 'quick' build that often causes issues / skips errors that will crash a proper package. If you see errors in the packaging address them and try again..

 

Let me know if that works/or doesn't.

>>> Are there any errors when you use VRPreview?

No, not at all. I've attached the log. You can see it in details.

 

>>> How are you building to headset? 

I've packed my project as your suggestion.

- For Android_ASTC => Nothing happen

- For Android_DXT => Nothing happen

- For Android_ETC2 => Only sound played

 

I think android stuffs can affect to the result. Here is my android environment.

- Android studio 4.0

- Android API 32

- Android SDK build-tools  33-rc1

- NDK 21.4.7075529

- Gradle 6.1.1 (defined in Engine\Build\Android\Java\gradle\gradle\wrapper\gradle-wrapper.properties)

What is your android environment?

 

I've attached the log for install APK. You can see it in details.

Please see Logs here!

pro_zac
Level 7

The log you supplied is from the batch file installing the apk. You'll want to take a look at the log output on the headset. I recommend installing ODH and using the "Device Logs" button. 

Yes, I've also checked the device logs but not detected any issue.