Showing results for 
Search instead for 
Did you mean: 

Packaged app does not start, black screen

Honored Guest


I am working with UE 5.3.2 on Windows 10 deploying on Oculus Quest 2. 

I packaged and installed the app I am developing. After installation the app does not start. I run it from Unknown sources, it never changes the view to the game view.

It either:

1. Does not react at all

2. Turns black for a second and turns the app off

3. Turns the screen black for a second and leaves the app minimised, when turning it maximized it turns the screen back to black for a second again and nothing changes.

I have tried referring to several tutorials which are mostly referring to older versions of Unreal or to troubleshooting of this similar problem, like this: . Those proved to provide more options that are version specific or case-specific, none of them worked.

Among things I have tried:

1. Changing SDKs and NDKs.

2. Disabling OpenXR.

3. Deploying with different settings (development/shipping/others ASTC/DXT/others).

If I should set one of those to something specific (for example that I should always try to deploy ASTC, for the time of the troubleshooting, please let me know).

Right now I am kind of losing hope and am looking for some guidance where should I be looking for next steps. Right now I am referring to UE5 documentation, let me know if thats the right approach. Specifically I am trying to use this:


Honored Guest

Hi there,

Try this: on the project settings > Plugins > MetaXR > General, change XR API from Oculus OVRPlugin to Epic Native OpenXR.

I had exactly the same problem when deploying to Quest Pro and this worked for me.

result is pretty much the same as previously

try a simple test with the VR template. just create a new project based on this template, accept the Android manifest and then package the game. See if it opens.
if it doesnt, maybe its a render settings or something similar. But first just package a blank vr template for test it

Honored Guest

Just FYI, I had a black screen and then remembered I had to re-enable the OpenXR plugins before packaging (I disabled them in order to use VrPreview in the editor). After OpenXR was re-enabled (and XR API was set to Epic Native... like aula.metaverso said above) the app launches fine.
Honored Guest

Did you put the meta plugin in the project's files directory


I have the same problem. If you are on the meta plugin v63 switch back to v62. You will need to turn openXR "off" for preview and "on" for packaging, switch the XR API to "EpicNative.." and it will run. I have not been able to run a single packaged app using the plugin v63. No problems on v62.

Expert Protege

It works on v63.

I leave OpenXR off, completely. 
Use Shipping with For Distribution Checked. (Development and For Distribution unchecked will work but you cannot save files/savegames)
Make sure to sign your app with Keystore and fill out Keystore Settings in your Android Settings or it will not work.

Here is my settings:
I have messed with an absolute ton. Some of these will break your app, it's so hard to tell other than with trial and error.

Android SDK:


Meta XR

Android Settings: 


More Android Settings:


Make sure to sign your app and fill out keystore settings.


Mobile Shading Settings:
(Mobile Float Precision Mode is by default Half-precision, but can also be Full. This makes the mushy mobile game texture graininess go away in trade for using more processing power.)

If you use Virtual Textures on mobile, make sure to enable it (altenatively, disable "Enable virtual texture support on Mobile" above)


VR Render Settings:

Lastly, set Start in VR to true.

This should do it.




Thanks for the guide. I followed your instructions and can now package a project with the Meta XR Plugin v63. Sadly it won't run as soon as I set the XR API to Oculus OVR Plugin. It still runs fine selecting the Epic Native Open XR. This turns out to be a massive time killer.

Disable OpenXR 100% for development and packaging, if you can manage within the scope of your project.
This should be the XR API setting and it should be grayed out.