Showing results for 
Search instead for 
Did you mean: 

Packaging Error "class is not mapped when saving"

Not applicable

I periodically get a packaging error that only occurs on child blueprints.


It causes an unrecoverable assertion:

Assertion failed: !Export.ClassIndex.IsNull() [File:C:/OUE/Engine/Source/Runtime/CoreUObject/Private/UObject/SavePackage.cpp] [Line: 3807]
Export SKEL_ZombiePC_C /Game/XXXXXX/Zombie/ZombiePC.Default__SKEL_ZombiePC_C class is not mapped when saving /Game/XXXXXXXXX/Zombie/ZombiePC
UE4Editor-Win64-DebugGame.exe has triggered a breakpoint.


I can typically relaunch and repackage without issue.


It has happened on multiple child blueprints.


Thanks for any help



Not applicable

Not applicable

[UPDATE]  So this is definitely annoying.  Will get crash when launching to device if there is a child blueprint of a blueprint referenced.  Typically, you can simply realunch editor and package right away and it works.  Doing work in the editor causes some kind of error to happen when packaging with a child blueprint.


As if launching to device in Unreal wasnt already pretty slow... now it susually crashed and I have to relaunch editor 😞

Honored Guest

Found a solution that worked for me by going into Saved/Cooked and Saved/EditorCooked locating the file and removing both the Uasset and Uexp version of it, then relaunching. or repackaging. Hope this will help someone.

Honored Guest

I had same issue. CDO from transient class is not marked as transient after blueprint regeneration. 

This change fixed it for me