Showing results for 
Search instead for 
Did you mean: 

[SOLVED] Can't find the Sessions with Unreal blueprint nodes.

Level 5


I have been trying for a while now to get Unreal to find Oculus sessions that I create but nothing I do seem to make it work and I am not sure why at all.
Is this meant to work with blueprints?

I have tried with both simple default Pools, Advanced Pools and Custom Pools.
But never got a valid return from the FindMatchmakingSessions blueprint node.

I get Oculus user ID's fine so I know the basic setup is correct. Also I manage to create the session fine.
I just never seem to be able to find the sessions, allowing me to then join them.

This is one of the ways I have tried:
gets me:  (note, the 'join' in the screengrab here is by the id that did the create session, ie an auto self join)

But then I don't get any data doing:

We are using UE4.18.1

Is there anyone that can clarify how this is meant to work?
I need to get that 'Result' array so that I can chose and feed into the 'Join Session'.


UPDATE:   The magic combination seemed to be to use a 'Custom' pool and also on the session start do a:  'open mapname?listen'.
I then managed to find the session with the above 'T' command although it seemed a bit flakey. Only works on second 'T' run for example.

[I will move the below bit to a new post with a more fitting header]
The problem is still that the second player doesn't get moved to the map opened by the first player (in listen mode).  It was suggested to me that I should be able to do : 'open  oculusIdOfListenServerPlayer.oculus'  to make the second player join, but that is not working.
Does anyone know how I can do the joining using blueprints?


Not applicable
I'd also like to know if this is finally possible with blueprints now! 🙂

Data use checkup request needed to be approved. I was then having all OSS features working immediately.

Level 5

I'm sorry but.... This isn't Solved