cancel
Showing results for 
Search instead for 
Did you mean: 

Elite Dangerous launch error in Rift S

CGH001
Level 4
I've not played ED for a couple of months, although I did let Oculus do the January ED updates. Now, whenever I launch in VR or desktop mode using the Oculus launcher I get 'Unhandled exception: Object reference not set to an instance of an object' whenever the ED sign in screen opens.  It then closes the window and I can't play the game.

Has anyone else got this message please?

I can get it to run using the ED.exe in the games folder (although this seems to give some issues with Voiceattack and HCS  for some reason) and google reveals some debate re the .NET framework which doesn't seem to be an issue on my system.

Thanks.
18 REPLIES 18

waltor64
Level 2


Hi there, 

I am sorry to know that you have experienced
this issue! This is often related to .NET I'm afraid. You should be able to circumvent the issue
by running through the following:

On C:\Program Files (x86)\Frontier\EDLaunch you should
find a file named EDLaunch.exe.config.

For Steam installs, it should be here: C:\Program Files
(x86)\Steam\steamapps\common\Elite Dangerous


·        
Firstly,
make a backup of this file by copying it to another location, such as your
desktop.



·        
Open the
EDLaunch.exe.config file with a text editor such as Notepad. You'll see
something similar to:



<supportedRuntime
version="v2.0.50727"/ >
<supportedRuntime version="v4.0"/ >

Switch the lines, so they look like this:



<supportedRuntime version="v4.0"/ >
<supportedRuntime version="v2.0.50727"/ >




Once you have done this, save the file and attempt to start up the
launcher. If it's still not working you can just replace the file with the
backup you created.


If you continue to have problems, please submit a ticket so that we can investigate further.

Thanks,

CMDR Sputnik



Oh my God! I have been trying to resolve this issue since I started Playing ED in December. Everytime I have had to back into the desktop and clear the errors crashing the launcher but keeping the game playable. When I wanted to shift from regular play to the FC Beta I had to fool around with it for hours to get it working without the launcher. Now the launcher works perfectly and I can switch back and forth at will. Can I buy you a beer or something? I have tried every suggestion I have found but yours not only worked it was written in way that could be followed. THANK YOU!!!

RattyUK
Level 10

waltor64 said:



Hi there, 

I am sorry to know that you have experienced
this issue! This is often related to .NET I'm afraid. You should be able to circumvent the issue
by running through the following:

On C:\Program Files (x86)\Frontier\EDLaunch you should
find a file named EDLaunch.exe.config.

For Steam installs, it should be here: C:\Program Files
(x86)\Steam\steamapps\common\Elite Dangerous


·        
Firstly,
make a backup of this file by copying it to another location, such as your
desktop.



·        
Open the
EDLaunch.exe.config file with a text editor such as Notepad. You'll see
something similar to:



<supportedRuntime
version="v2.0.50727"/ >
<supportedRuntime version="v4.0"/ >

Switch the lines, so they look like this:



<supportedRuntime version="v4.0"/ >
<supportedRuntime version="v2.0.50727"/ >




Once you have done this, save the file and attempt to start up the
launcher. If it's still not working you can just replace the file with the
backup you created.


If you continue to have problems, please submit a ticket so that we can investigate further.

Thanks,

CMDR Sputnik



Oh my God! I have been trying to resolve this issue since I started Playing ED in December. Everytime I have had to back into the desktop and clear the errors crashing the launcher but keeping the game playable. When I wanted to shift from regular play to the FC Beta I had to fool around with it for hours to get it working without the launcher. Now the launcher works perfectly and I can switch back and forth at will. Can I buy you a beer or something? I have tried every suggestion I have found but yours not only worked it was written in way that could be followed. THANK YOU!!!


Nice when something so simple works so well, isn't it?
I'd usually do a .net repair and reboot to get around it...  Then this post happened - end of issues.
o7 CMDR 🙂
PC info: AMD Ryzen 7 2700X, MSI MPG X570 Edge, 16GB Tforce Pro Dark DDR4 3200, KFA2 RTX 2080 Super, Samsung 870 Pro M.2, 2x 240GB SSD, 3TB WD Green HDD & 4 TB Seagate Barracuda HDD, Antec Modular 750w PSU, custom watercooling loop. (Win 10 Pro & Opensuse Leap 15.1 Linux) 32" AOC 4K Monitor.
Rift S
Laptop: Aorus X5 V6-CF1 (I7-6820HK, GTX 1070, 2* 256GB M.2 NVME, 1TB 7200 HDD)

SergioBR1
Level 2
FrontierSupport said:


Hi there, 

I am sorry to know that you have experienced
this issue! This is often related to .NET I'm afraid. You should be able to circumvent the issue
by running through the following:

On C:\Program Files (x86)\Frontier\EDLaunch you should
find a file named EDLaunch.exe.config.

For Steam installs, it should be here: C:\Program Files
(x86)\Steam\steamapps\common\Elite Dangerous


·        
Firstly,
make a backup of this file by copying it to another location, such as your
desktop.



·        
Open the
EDLaunch.exe.config file with a text editor such as Notepad. You'll see
something similar to:



<supportedRuntime
version="v2.0.50727"/ >
<supportedRuntime version="v4.0"/ >

Switch the lines, so they look like this:



<supportedRuntime version="v4.0"/ >
<supportedRuntime version="v2.0.50727"/ >




Once you have done this, save the file and attempt to start up the
launcher. If it's still not working you can just replace the file with the
backup you created.


If you continue to have problems, please submit a ticket so that we can investigate further.

Thanks,

CMDR Sputnik



I would like to thank you very much CMDR SPUTNIK, i have been looking for a solution on general sites for months and today i found here, works fine to me.

Anonymous
Not applicable
Hi, I'm having the Unhandled exception: Object reference not set to an instance of an object error when trying to play in VR or not (Rift S). I've tried the edit on the EDLaunch and it didn't work I just got an error and couldn't play the game at all and I couldn't get the .NET to update/ fix it's self.

FrontierSupport
Level 6
Hey CMDR, 

Please send us a ticket via the button at the bottom of this page: https://customersupport.frontier.co.uk/hc/en-us/articles/360011920879-Install-error-message-Unhandled-exception-during-project-update-object-reference-not-set-to-an-instance-of-an-object- and we'll be happy to help. 🙂

-CMDR Vulcan 

BigBonk
Level 2

hi i found a fix i just hit delete on ED launch application then clicked undo and now it loads up. bought this yesterday and kept getting a no object message

CptPillowFort
Level 2
I'm having this problem as well. The ED launcher come up. I click play. Then it brings up an another screen to submit a crash report. I tried the solution for editing the file given by Frontier in this post and it brought up a new error in steam.

av8rgeek
Level 2
I just want to say thanks to @FrontierSupport for their solution.  It worked for me and I have had this problem for years.  My installation was from the Oculus store, not from the standalone or Steam.  None of the documentation on the websites references this specific issue.  I've uninstalled and reinstalled .NET Framework, reinstalled Elite:Dangerous, updated drivers, tried the clean boot, and nothing seemed to help.  I've even had tickets open with both Oculus and FDev support.  Oculus support said it wasn't their issue and FDev's support pointed me to the FAQ, which cleared things temporarily, then it was right back to this same error.  When in VR. the game would load fine, but I always had those errors.  It's nice to see this solution worked.  

PLEASE update the installer for Oculus so the XML file is a) Properly formatted (for human reading...indentation and all), b) add this solution to the FAQ on your website so it's not buried in a non-FDev forum, and, most importantly, c) change the .NET Runtime supported line order so that v4.0 comes first so this error is fixed!

Gratefully and Respectfully yours,

CMDR Av8rgeek

Grocs
Level 3
Thank you for the solutions provided here. I think it must have been a combination of altering the config file and using the Fix.Net option. All is working again with the exception error. Much appreciated.