cancel
Showing results for 
Search instead for 
Did you mean: 

Library apps keep crashing

adam_mcinnes_73
Level 2
I keep having issues with the library apps crashing. I have no problems using ones like the DreamDeck, First Contact, and Avatar, and I am able to play Elite Dangerous on SteamVR, but any other app that I try to use keeps crashing after maybe a minute into running whether I am doing anything in the apps on both the Oculus app and SteamVR (e.g. Google Earth VR, Travel VR, etc.). I can't figure out what is going on here. I don't get any warnings when this happens either. I've tried watching the performances in the Task Manager, and there is nothing there to suggest why it keeps crashing; the only thing that shows up is a sudden drop then spike in the 3D performance on one of the graphics card right as the app crashes, but otherwise it is running just fine while the app is running. I've also tried monitoring the heat of the system while running the apps, and again, I see no issues popping up there (the heat doesn't really change while the apps are running). Here are my system specks:

MB: Asus Z170-A
CPU: Intel i7 6700K overclocked to 4.6 GHz (liquid cooled)
RAM: 32 MB DDR4 3200 MHz (running at 2100 MHz)
Graphics: 2x GeForce 1070 in SLI
BIOS: 3802 (the latest version)
Oculus Rift CV1 (firmware is updated to the latest versions)
OS: Windows 10 64-bit

Frankly, I have really not been impressed
with Oculus so far (though the Rift itself has been great, and I like the Touch controls better than the Vive). I submitted two service tickets (with logs),
but never heard back on either one. I finally figured out my problem in
these forums (I had to turn down my RAM speed from 2933 MHz to 2100 MHz or
the Oculus had poor tracking and was jumping all over in virtual
space). I also had to purchase an
extra USB 3.0 card to run this system (though the first PCIe USB 3.0 card that I bought at a local store was not compatible), despite my motherboard already
having two USB 3.0 and one USB 3.1 ports that I was using for the
sensors and headset (though the extra ports will be nice if I upgrade to extra sensors for a full room down the road). Now I am dealing with a possibly blown speaker in the left ear
piece (it's very apparent with bass tones, despite this unit essentially being brand new), so I may have to return this
unit to the store where I bought it for an exchange (the first unit I purchased also had to be returned because it kept disconnecting). Figuring out the sound issues was also annoying (at the start, it required manual switching between the Rift and the computer speakers in the system settings, but that seems to have resolved itself). Suffice to say, for the amount of money I spent on this, I
am really not happy with the support and equipment from Oculus, not to
mention the almost complete lack of available knowledge base for trouble
shooting besides the forums. Anyways, enough bitching about past issues, as I have finally
got most of them fixed, but I probably wouldn't recommend Oculus to people going forward after my experience with the technical side of things unless they are tech savvy and very experienced with computers.
3 REPLIES 3

adam_mcinnes_73
Level 2
I think I finally figured it out. I was looking through the tabs in the Settings menu, and in the Beta tab, there was a section called "Demo Mode" was was on. I turned it off, and the apps started working properly. Talk about annoying. I'll keep this post here in case anyone else is having this same problem. I'm curious what purpose the demo mode serves.

nadhim
Level 2
majority of the apps are crashing. even contacts are not opening. please provide assistance for this issue. i did reset my phone but it didnt work for me

cybereality
Level 15
Please feel free to submit a support ticket for help. Thanks. https://support.oculus.com/
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV