Showing results for 
Search instead for 
Did you mean: 

Medal of Honor - Unable to accept terms of service

Level 2

I just bought Medal of Honor Above and Beyond. Everything goes well until i can't accept the terms of service. Anyone have a solution or fix for this issue? i'm using Oculus Quest 2 128gb. Thank you


Community Manager
Community Manager

Hey there @snackers.445895! We're sad you're experiencing this issue. We know how important your gametime is and we'll be happy to help!


To get a better understanding of the issue, can you send a screenshot of the message you get when you try to accept the terms?


We do appreciate it!

Community Manager
Community Manager

Hey snackers!


Just stopping by on our way to the support store and we wanted to check in on you. Were you able to resolved your little predicament or do you need a helping hand?


We look forward to hearing back from you

Hi .. it seems that the right controller doesn't work when i try to pointed the accept button. Tried to reset to the factory default still doesn't work.

This isn't what we like to hear. Please submit a support ticket so that we can look further into this for you and see what available options we have open for you.  


We look forward to hearing from you. We're always here to help!