Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 Windows 11 Performance. can never hit maximum FPS with link cable.


I decided to give windows 11 a go and everything on my PC is working flawlessly apart from one big one... Oculus Link performance. Before I go back to windows 10 I wonder if anyone has figured this out already.


Oculus software works fine and the Quest 2 link connects, but it can never hit the required fps settings no matter what they are. So if I have link set to 90hz, then in game it will be about 82-85fps and stuttering, it never hits 90fps even though the game says its locked at 90 on my monitors no problem, and I have loads of headroom in performance monitor (I have a 5900x and RTX 3090!) - If i use the 120hz option then i will get about 105fps but never 120. Even if i choose 72hz ill get about 65fps. super annoying.


I went onto the beta channel on the software and got the latest updates but still no luck.


I dont mind going back to windows 10 and i get windows 11 might not be ready yet, but literally EVERYTHING else on my pc works fine, only the vr performance, so its a shame. Any ideas of things to try before I reinstall windows 10?

453 REPLIES 453

Grand Champion

Windows 11 is unsupported. When using beta software you're on your own. 


And rule number one - do not upgrade until Oculus is ready - don't try to be ahead of Oculus if you value everything working. Thus don't buy a new gpu shortly after it is released etc. 


Oculus may take months to support new hardware and software. 

Oculus Rift CV1, Valve Index & PSVR2, Asus Strix OC RTX™ 3090, i9-10900K (5.3Ghz), 32GB 3200MHz, 16TB SSD
"Ask not what VR can do for you, but what you can do for VR"

Wow what a ‘helpful’ answer


dude of course I know it’s beta and not guaranteed to work. I’ve been building pc’s since ms dos was the operating system.. I was just wondering if someone has found a solution, assuming this is a forum to actually discuss and help people rather than being condescending. Windows 11 is basically just a reskinned windows 10, so it’s actually surprising it doesn’t ‘just work’ as literally everything else does.


but it’s no trouble to roll back to windows 10 if it’s a known issue.


 Been building since those days too, sure been a long ride.  Just a few things you may not have considered. Tried all the graphics drivers you have available? Any chipset or bios updates for your motherboard?  Other than that I kind of doubt many have tried. I'm happy and surprised to hear it is working at all in the Win 11 beta. I doubt there will be much advantage for VR until we are closer to DX13.      

Gigabyte  AB350 Ryzen 2700x, 32gb ddr 4 3200, 2080ti. HP Reverb G2, Index controllers, Quest 1 and 2x Quest 2. 65" 3DTV HD3D DLP projector.

I tried a few different drivers, chipset drivers and a couple of windows versions. Sadly I couldn’t fix the stuttering my side. It just never hits the locked frame rate, always 5-10fps lower than whatever the target is which obviously feels like a terrible stuttery mess.


some people are reporting windows 11 working perfect fine for them though which is strange. Gaming performance everywhere else is identical to windows 10.


anyway for now I’ve gone back to windows 10, and it’s smooth as silk locked at 120hz. If I hear reports that’s it’s been fixed I’ll give it another go as I very much like everything else about win11.

According to this post, a user was able to fix performance by updating the OS to build 22000.71:


I tried out 22000 the same day it came out (probably not the .71 build mentioned) and can confirm Link was a stuttery mess. Back on the leaked 21996 build, Oculus Link would work fine for exactly 25 seconds, after which it became a stuttery mess.


I don't know the reason, but it seems like GPU encoder usage is low, which implies Oculus can't use as much of the GPU encoder as it needs to. Normally I see 70-80% Encoder load with Link on Windows 10, but on 11, it was around 20%. I have a RX 580, and on Windows 11, I tried both the preview WDDM 3.0 drivers, and the latest (at the time) 21.6.2 WDDM 2.7 official AMD driver, and had the same issue with Link with both. I haven't revisited W11 since then nor do I know if the .71 build or other future W11 updates have fixed it.


On another note, Virtual Desktop seemed fine, so (assuming it still does), it and other wireless PCVR apps (ALVR, AMD Relive VR) may be fine too and be a potential alternative if Oculus still doesn't work correctly.

Quest 2 | 2700X | 6600 XT

Grand Champion

Seems like Nvidia is ready with the first Win11 driver - I just read this:

Oculus Rift CV1, Valve Index & PSVR2, Asus Strix OC RTX™ 3090, i9-10900K (5.3Ghz), 32GB 3200MHz, 16TB SSD
"Ask not what VR can do for you, but what you can do for VR"


 build 22000.71 didnt fix it for me - maybe its a hardware combo thing (im 5900X, Asus X570 Crosshair VIII and RTX 3090)


Went back to Windows 10 for now and happy, but I am running win11 on my work pc and really really like it. I would like to have my gaming rig on it also but only when VR link is 100%. Ill keep an eye out for updates that specifically mention it for sure. 

Expert Protege

I've heard Windows 11 build 22000.100 is available now. I'd like to hear feedback from anyone as to if Oculus works in that build or not.

Quest 2 | 2700X | 6600 XT

Windows 11 build 22000.100 works fine with air link and VD with Quest 2 V31.