Showing results for 
Search instead for 
Did you mean: 

Quest 3, warnings about debris or liquid damage when plugging the USB-cable

Got the Quest 3 ten days ago. I've gotten warnings about USB-port containing some debris or liquid, when unplugging or plugging the USB-cable to Quest 3. This has also happened when I power up the headset with its power button. It is a popup window with this warning message.
I have no idea if this is software or hardware issue.
I got this message first time when I booted the headset for the very first time and plugged the USB-cable to headset.
There is obviously no liquid damage or visible debris in the USB port, the device charges OK, I've charged the headset maybe 2 to 3 times, and today I again got a warning when I pressed the power button and the headset booted.

Honored Guest

Just used my Quest 3 first time. After 2 hours got the same Fluid in Headset warning. Curious if it will happen again.

Honored Guest

I just had this after no actual water damage. It now says it every time I turn the headset on! Any updates on your end? 


I returned my headset, got another Quest 3, but I haven't yet opened it, been too busy before weekend.

Anyway, I doubt it has anything to do with liquid, guy in the shop I bought my Quest 3 from was guessing it could be some sort of faulty sensor - who knows.

I'm getting the same issue on my Quest Pro. It's been in a case and no possible water damage. Wondering if there's a software issue.

Honored Guest

done nothing different and the message has disappeared. For now. I’ll update if it comes back. I contacted meta and they were willing to replace so don’t worry if this happens to you. 

Meta Quest Support
Meta Quest Support

[NOT A SOLUTION] - Just marking this as the solution for visibility

Hey everyone! I noticed this thread getting a bit of traction, so I wanted to get this flagged with the right team. 

To get this into the right hands, could everyone still running into this please answer the following:

  1. Could you provide a photo of the error message?
  2. Does it happen when using standalone, connected to PCVR, or both? 
  3. What's the full version number of your headset? (57.0.0.####### or likewise)
    • Quick Settings > System > Software Update
  4. Is your headset on PTC?
  5. Any potential workarounds?

As soon as I get this, I can get this looked into more in-depth! 

Sometimes it's okay to be a little Bing Chilling

Heads up everyone, this AntiSocializer is going around to several unresolved posts marking them as resolved. Their whole job is seemingly to fraudulently mark big issues that Meta wants to keep quiet at resolved even though they are not resolved at all.


Re: Quest 3 app sharing not working


Re: Anyone else seeing terrible lens glare like glasses without anti-reflective coating?


Re: Cant view synced videos on Meta Quest app


Just a few here. There were several more but they wait until the noise dies down, then they edit the [NOT A SOLUTION] part out but do not change the resolved status.


Well that is a strange way to operate I must say - not going to speculate why - but no one is going to read a small print inside a thread ("NOT A SOLUTION").

If the issue is not solved or explained, there is no reason to mark anything "solved" - SMH.

Just marking this as the solution for visibility    

That's the reason.

People with the same problem find this thread easier and can post the information @TheAntiSocializer  asked for here.

That might help to solve the problem faster.